1

I am trying to deactivate Auto-login on the system settings/user accounts, but it even after I reboot the computer it will still log in automatically.

cat /etc/lightdm/lightdm.conf

1
  • Can you post the output of cat /etc/lightdm/lightdm.conf? Sep 16, 2015 at 17:43

2 Answers 2

3

You dont' need your lightdm.conf file. I would rename the file as to make the system believe it isn't there. I only hae pantheon-greeter.conf and users.conf in my /etc/lightdm/ folder, and I don't have auto logins.

Make your /etc/lightdm/pantheon-greeter.conf look like this, too:

enter image description here

I really don't think you need a lightdm.conf for elementary. Try renaming the file.

1
  • I had this problem after deleting a user that was set to login automatically. Deleting lightdm.conf resolved the issue.
    – Sysfu
    Jun 2, 2019 at 19:49
1

I am having a similar problem. Recently, on boot up or restart, my eOS system has been auto logging into one of the user accounts (call it user A) even though it has always been configured not to. After auto logging in user A, I can log in with user B, then log out of user A, then log out of, or restart, from user B and get the greeter showing the users. Logging into user B requires a password, but selecting user A logs in user A without a password. Also renamed /etc/lightdm/lightdm.conf and ensured io.elementary.greeter.conf as above, with no affect. Any ideas on where to start looking to troubleshoot this issue?

Computer: Dell Inspiron 15-7568 laptop OS: elementary OS 6.1 Jólni, latest updates

$: lightdm --show-config

[LightDM]
A logind-check-graphical=true
C backup-logs=false

[Seat:*]
A greeter-session=io.elementary.greeter
A user-session=pantheon
B allow-guest=false
D greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
E guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
F xserver-command=X -core
G autologin-user=

Sources:
A /usr/share/lightdm/lightdm.conf.d/40-io.elementary.greeter.conf
B /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
C /usr/share/lightdm/lightdm.conf.d/50-disable-log-backup.conf
D /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
E /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf
F /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
G /etc/lightdm/lightdm.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.