3

I recently installed elementary os freya 0.3.1 . At first , when I tried it from usb , the os ran smoothly considering it wasnt a native install. However, after I installed it ,it lagged pretty bad! Files took forever to load and close and graphics were really choppy. Plus, the fan wouldnt slow down and made noise the whole time. I tried installing the nvidia drivers from the Additional drivers tab but nothing changed . I have a compaq presario cq61 which seems totally compatible ,and every other distro I have tried runs pretty smoothly.Any suggestions?

  • I have freya 0.3.1 installed in an USB myself and it runs quite smoothly. I don't have a swap partition, though. That tends to slow the system down if you have enough RAM, besides reducing the lifespan of the USB stick itself. Do you have a swap partition? – user2418 Sep 17 '15 at 8:37
  • I installed the os using the default options of the installer so I guess it created a swap partition – Aris Sep 17 '15 at 9:55
  • You have to use the "Something else" option to install it without swap. After re reading your original post, however, I am not sure: did you mean you installed it in the USB stick? I was assuming that. – user2418 Sep 17 '15 at 9:58
  • No, i installed it normally. I just tried it before installing from the live usb – Aris Sep 17 '15 at 10:19
  • Oh, I see. In that case something else might be happening there. Maybe someone else has experience on this and can add some perspective. – user2418 Sep 17 '15 at 11:09
1

Your hard drive might be slow.Try replacing the hard drive with a new one or an SSD.Slow disk access can make your system slow.The USB does not use the disk but the USB instead so it is faster

protected by Community Dec 29 '15 at 9:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.