0

enter image description hereI‘ve just got a Toshiba Satellite Pro C50A which came with Windows 10 pre installed.

I‘m installing Linux onto this laptop for a friend who‘s technophobic, schizopjrenic, and on medication. One of the main uses, if not the main use will be to watch downloaded videos and/or streaming videos.

Unfortunately, when I first got this laptop, there were problems with the DVD drive and it seemed that Windows 10 was making life difficult as well. The DVD drive wouldn‘t boot up from any Linux Live DVDs, although it displaed their contents on the Windows desktop. Eventually, it started ejecting all DVDs, saying “Please insert a disc“. I bought a DVD cleaner disc and cleaned it, but this made no difference. I tried to clean it again, but it just ejected the disc!

I‘ve since been given a replacement DVD RW drive by the seller.

Before I fitted the replacement DVD drive I felt I had to stop Windows from starting up by pressing the Power button. I wasn‘t sure exactly what was happened with the Linux Live DVDs I was trying to boot from. This may have caused problems later.

After fitting the new DVD drive, things improved. The DVD names and contents were displayed on the Windows desktop. However, however when I tried to boot up from any DVD it always stopped at some stage. The error messages displayed were “The disk contains an unclean file system (0,0). Metadata kept in Windows cache, refused to mount“ that the Windows NTFS file system was in a unsafe state because Windows hadn‘t closed down properly. It demanded that I restart Windows, login, then close down, not us sleep mode or hibernation. I hadn‘t done either of those things anyway! It also recommmends me running chkdsk /r . I‘ve done this, let it run for over 90 minutes, until it said it was fixed, but it made no difference! Since then, it‘s even asked to do it again, and was scheduled to take 4-5 hours, so then I just stopped it! This Windows installation has just one user account called “User“ which logs in automatically as it starts up. I don‘t know if there‘s a password. After starting up and closing down Windows I keep getting the same error message! Not only that, but there‘s another error message that won‘t go away. This says “USB read error -22“. According to another message, this is caused by unplugging a USB device without first selecting an option to safely remove it. I haven‘t even done this and don‘t know how this message can keep coming up afer so many reboots, especially before booting into Windows!

  • Let's go part by part. I suppose you can't boot the live DVD so to boot it just log into windows and insert the DVD. Then go into advanced startup, follow the option 1 to do so and select your dvd. That should boot your dvd just fine. If you see that USB read error -22 it's alright, just wait a while and it will continue loading the installation setup. – Maccer Sep 7 at 13:32
  • If this doesn't work you may want to look into using a bootable USB instead of DVD. USBs are faster and it's less likely to find any data corruption error with them. You can use Rufus to create a bootable usb directly from windows. – Maccer Sep 7 at 13:34
  • It's the same old story. It still stops with the same kind of message sbout using chkdsk /r to correct it, as well as that it may be because of unplugging a removable device without first unmounting! I've just managed to add a pic showing the full message to my post abov! This happens with every DVD. It can't find the ISO. Perhaps I should just clean my DVDs, although they work on other laptops. – Paul Braun Sep 7 at 15:43
  • Create a bootable usb and use that. And maybe download again the iso file so that you are sure it isn't corrupted. – Maccer Sep 8 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.