0

As per title, turned on today my XPS 9550 and everything lags. Did not changed anything recently, just a BIOS update from the official Dell website.

Anyone experiencing this?


Well, as it came, it went away. Turn on the XPS later today and all is normal. Only thing that changed, was battery power instead of being charging/charged, no idea.

  • Ok, so actually the problem showed up again when I plugged the PC for charging. I found out that the latest BIOS published by Dell (1.11.2) made some changes along the lines of "Enhances thermal management of the system." This thread shows how others had the same problem. dell.com/community/XPS/… My solution was to roll back on BIOS 1.10 (meanwhile 1.11.2 has been deleted by Dell) and all is good again. Weirdly, Dell shows 1.9.0 as the latest one, I don't know why since 1.10 is newer and works. – Travis Aug 28 '19 at 7:47
2

Problem is caused by Dell BIOS 1.11.2, rolling back to 1.10 solved it.

Hopefully the next BIOS version will be fine.

EDIT: BIOS 1.12.0 has been fine, but the latest 1.13.1 (published January 6th 2020) has recreated the problem. Again, rolling back to 1.12.0 is the solution, but I would like to understand how the official BIOS can do this.

I also tried this solution, but no avail.

https://www.dell.com/community/XPS/Dell-XPS-15-9550-is-absolute-unusable-after-BIOS-update/m-p/7376573

Anyone else?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.