0

My problem is the following Who knows how? I'm not talking about the Elemementary App Store downloads. I mean programs from other official sites like for Epson printer drivers and scanners, where there is NO link/address to use "apt-get install <…>" etc. in terminal code. When I use the download button and unzip the download it opens bit I cant see the '.exe' button, only the folders * files - so it's not visible' in the "Apps" window - thus useless. When I try to open in in terminal editor I get: " unable to locate file" etc. So could you tell me how to, preferably, get the get the terminal address from the button on the download site or How to install the downloaded zip/.tar using the terminal code, with the correct folder indicators - thus a few lines of code plz.

  • I suspect, there may be more than one question in your question. Could you please provide an example of a third-party driver/software that you wanted to manually install in elementary OS but didn't succeed? – a-tokarev Aug 19 at 11:46
  • And would you please clarify, what '.exe' button are you referring to? – a-tokarev Aug 19 at 11:56
  • I am trying to install the printer driver for Epson WF-2010 & scan driver for Epson V-500. with .exe I mean the run/boot to launch the drivers. – Billie Glaser Aug 20 at 12:44
  • I am trying to install the printer driver for Epson WF-2010 & scan driver for Epson V-500. with .exe I mean the run/boot to launch the drivers. see Perfection V500 scanner driver here: download.ebz.epson.net/dsc/search/01/search/searchModule AND have installed the WF-2010 printerdriver, but it gives "connect printer cable, while when I change to Windows 10 on the same computer it works – Billie Glaser Aug 20 at 12:55
  • I did follow a link you provided. There was only one Linux driver for Epson V-500 (available on this page: support.epson.net/linux/en/…) After unpacking it produced a folder with 3 folders in it, with .deb install files in each of them. You can install .deb files easily with the help of Eddy app (from the AppCenter). – a-tokarev Aug 20 at 14:34
0

Please look at the screenshot. Is this the Epson Perfection V500 driver that you are trying to install?enter image description here ...

UPD: If the manufacturer's installation instructions have failed, here's what you could try:

  1. Go to your AppCenter. In the search field, type Eddy (this is a handy .deb packages installation helper), select and install Eddy application.
  2. Download the scanner driver archive from the Epson link. Make sure to choose .deb 64bit(amd64) version, if your processor is 64bit. In this case, the name of the archive will be iscan-gt-x770-bundle-1.0.1.x64.deb.tar.gz.
  3. In Files browser, right-click the downloaded archive and select Extract Here. This will extract the archive into the folder "iscan-gt-x770-bundle-1.0.1.x64.deb".
  4. Go to that folder. There you will find three more folders (core, data, plugins). Inside each of these folders you will find a file with a .deb extension. Double-click each of these .deb files and install them with Eddy. Reboot if necessary.

Good luck!

  • Yes indeed - I have also tried Vuescan, but Ed(the developer) says I need the Epson plugin first. Do you have a clear solution for me? If it's in terminal code then could you please send the exact code, as I'm new toLinux – Billie Glaser Aug 22 at 10:06
  • I will update my answer above. – a-tokarev Aug 22 at 10:24
  • please do, I'm very curious – Billie Glaser Aug 23 at 12:35
  • already done yesterday )) see my answer above, four steps after UPD – a-tokarev Aug 23 at 17:01
  • I use Eddy, but when I click the subfolders you mention I get terminal editor :( – Billie Glaser Aug 24 at 13:24
0

a.tokarev here is what I get when I try to open iscan.

also how do I put the plugin into my Vuescan app?

screenshot

enter image description here

  • If you intentionally scrambled the text on your screenshot, why did you do it? How is one supposed to read and understand it? – a-tokarev Aug 25 at 18:21
  • I'm very sorry, I definitely didn't scramble the text, I have no idea how this happened :( I just used the standard screen shot app, but now that I see it on my Windows laptop I can understand what you mean. When I ge back to my workstation I shall try to make another screenshot using the whole screen option – Billie Glaser Aug 27 at 8:41
  • OK now I've found the problem with the screenshots see my images. – Billie Glaser Aug 27 at 10:00
0

OK, now I found the problem with the screenshots. Also i tried the Terminal fix suggested in the instructions, bit to no avail :( Get the same fault report. Can you help please? see attachmentsfault message

enter image description here

  • What happens when you double-click the file "iscan-plugin.. .deb", which is selected on your screenshot? – a-tokarev Aug 27 at 12:15
  • I have just noticed that the printer utility is an .rpm package and I'm using Ubuntu, so it's obvious i can't unpack it correctly. Is there anyway to do this or with command line or a app? – Billie Glaser Sep 4 at 15:04
  • You can convert .rpm package to .deb format using Alien tool (and then install .deb with Eddy): linuxize.com/post/install-rpm-packages-on-ubuntu – a-tokarev Sep 8 at 8:00
  • And by the way, to install system printer (if yo haven't done that already), execute sudo apt install system-config-printer. Do that and see if your system will see your printer. – a-tokarev Sep 8 at 8:03
  • Thank you Mister a-tokarev the WF-2010 printer works perfectly now!!! You really hepled me out. Now my Stulus pro -3800 makes contact but freezes on "hold" in print queue app ... Also have to sartt scanner see what happens ... – Billie Glaser Sep 9 at 10:52
0

It seems that I can only send one image at a time here so sorry for all the postsenter image description here

0

enter image description hereIt seems that I can only send one image at a time here so sorry for all the postsenter image description here

0

OK here is what I get, it seems to be installed but does not seem to get into the Vuescan or iScan app. But non of my usb printers connect either, one says it's printing but I get no result on paper(WF-2010) . My Stylus pro 3800 just does nothing .. so maybe we should look at how to check if the usb periphials are visible. Btw I do see external usb HDD's when I connect them,

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.