0

I just did a fresh install of Juno on my laptop and I am not able to browse. I am able to ping my router and am even able to ping google.com by the IP address, but not by host. I'm concluding this is a dns config problem. This is true for both wifi connections and hard-wired network connections. I have configured the "additional DNS servers" in IPv4 Settings with the open dns servers, but still can't ping www.google.com. Any ideas?

Another strange thing is that I am able to browse to github.com but no other sites. My /etc/resolve.conf has the following entries:

nameserver 127.0.0.53
search san.rr.com

I also notice that when I ping www.google.com, it is resolving to an ipv6 address. I've never had luck with using ipv6. Is there a way to disable it? Could this be the problem?

0

Hay How are you.

can you send a screen shot of your network settings.

settings > network > advanced >

sounds like you have IPv6 turned on > go to the ipv6 tab and change the drop down method from automatic or what ever it is to ignore > save

What is the IPv4 tab showing?

your DNS should be set to your internal GW (router) which is normally used for DNS internally and to the outside world.

the 127.0.0.0/24 subnet is usually used as an internal ported range and not for use on a network.

what the supplied resolve.conf output is telling you is that the DNS network should use the computers internal route for DNS.

Does your router use DHCP to assign an IP address, GW and DNS?

You may have a manually set IP address in your IPv4 settings then you will need to manually set a static entry for DNS and GW.

If this is the case set your router as the DNS server or change to DHCP and let your computer grab an IP range from the router.

send those screen shots and lets see what is currently setup.

""Cheers G

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.