My setup is the pantheon DE (and a it's apps like files and terminal etc) installed on top of ubuntu 18.04. I've had this setup for about 6 ~ 7 months with no issues.

After a routine system update very recently, the pantheon DE options has disappeared from the list of available DE on the system and only ubuntu and ubuntu (wayland) are available.

Now i have a Frankenstein of a system with a mix of elementary and ubuntu apps and settings.

Things I've tried so far:

  1. reinstall elementary-desktop
  2. reinstall lightdm
  3. reinstall pantheon-greeter

Thanks for reading !

  • Same problem here. xsession file seemed to be removed from /usr/share/xsessions so I added one with the pantheon settings. Now appears on the list but fails to load and returns to the lightdm. Commented Aug 20, 2019 at 15:32
  • Same here. The first I knew of it was when I had to restart and the Elementary DE wasn't listed. I tried uninstalling and reinstalling to no benefit. In the end, I've uninstalled and found a U18 theme that is more or less acceptable and am running that - I like some Gnome3 features but miss more ElementaryOS features. Would like to go back to the ElementaryDE but so far have failed to find a cause.
    – rolandw
    Commented Aug 20, 2019 at 17:38

2 Answers 2


I've found that with an update of an elementaryos component, they updated a dependency version of the package libmutter-2-0, version 3.28.4-0ubuntu18.04.1+elementary4~ubuntu5.0.1, which is not from the ubuntu repo but from another elementaryos specific, ppa:elementary-os/os-patches.

Due to this missing dependency, apt removed packages gala and pantheon-shell.

Added the ppa, installed both packages, and got it working.

Hope that helps

  • This answer helped me a lot -> but I merely executed sudo apt install pantheon-shell in the terminal and it fixed everything. My entire desktop was returned just the way it was BEFORE it disappeared. After restarting the laptop I simply selected Pantheon from the gear icon above the login box - and all was well with the world again. I am running elementary OS Loki btw.
    – SilSur
    Commented Apr 14, 2020 at 8:44

A working installation has the following

   ll /usr/share/xsessions 

   total 12K
   -rw-r--r-- 1 root root 183 Sep 14  2018 pantheon.desktop
   -rw-r--r-- 1 root root 323 May  2  2018 ubuntu-communitheme-snap.desktop
   -rw-r--r-- 1 root root 247 May  2  2018 ubuntu.desktop

   cat /usr/share/xsessions/pantheon.desktop

   [Desktop Entry]
   Comment=This session provides elementary experience
   Exec=gnome-session --session=pantheon

Restoring that might help. Not sure why it has been removed from the package and more investigation will be required.

  • Thanks for the answer ! However I had given up and just reinstalled the whole os from scratch. Maybe others might be able to chime in with results ?
    – Jones
    Commented Aug 21, 2019 at 11:32
  • Sorry to hear that, I have just found the solution. I'll post it as answer Commented Aug 22, 2019 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.