0

I just switched from windows to elementary OS Juno.

My Ethernet works perfectly. I only have issue with the Wifi, I've been trying a bunch of drivers and no success yet. I ran the following commands:

iwconfig shows:

lo no wireless extensions.
eno1 no wireless extensions.

inxi -nx shows:

Network: Card-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
           port: 4000
         bus-ID: 02:00.0
             IF: N/A
          state: N/A
            mac: N/A
         Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
         driver: r8169
              v: 2.3LK-NAPI
           port: 3000
         bus-ID: 03:00.0
             IF: eno1
          state: 

The laptop brand and model is: HP PAVILION 15-cs0022cl

Thanks in advance

6
  • Check this thread. Maybe your problem is related to proprietary drivers : elementaryos.stackexchange.com/questions/16806/…
    – roypen
    Aug 14 '19 at 23:00
  • My Ethernet works perfectly. I only have issue with the Wifi, I've been trying a bunch of drivers and no success yet. I ran the following command. iwconfig lo no wireless extensions. eno1 no wireless extensions. inxi -nx Network: Card-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter port: 4000 bus-ID: 02:00.0 IF: N/A state: N/A mac: N/A Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 03:00.0 IF: eno1 state: down mac: Aug 14 '19 at 23:30
  • I had similar problem but only when I checked to install proprietary drivers for WiFi during installation process.
    – roypen
    Aug 15 '19 at 8:58
  • I've been struggling with this drivers. I dont know what else to do, with this no wireless extensions. Aug 15 '19 at 17:04
  • i dont really understand why this is marked as duplicate when its not. Not the same brand/mode or Wifi driver as the others question here asked before. Please, is there anything I can do to fix this issue, i've been struggling and no success yet. Aug 19 '19 at 13:29
0

This answer is very, very late but, for anyone who is still struggling with the RTL8821CE and using a Linux kernel older than 5.4, you can do this:

  1. Reboot the machine and enter the UEFI/BIOS
  2. Disable "Secure Boot"
  3. Boot into Elementary

Once eOS is loaded:

  1. Open Terminal
  2. Disable validation on mokutil:
    sudo mokutil --disable-validation
    
  3. Grab the Generic HWE kernel:
    sudo apt install linux-generic-hwe-18.04
    sudo apt update && sudo apt upgrade -y
    
  4. Reinstalled the dkms headers:
    sudo apt-get install --reinstall git dkms build-essential linux-headers-$(uname -r)
    
  5. Clone tomaspinho's GitHub repo for the RTL8821CE:
    git clone https://github.com/tomaspinho/rtl8821ce
    
  6. Change to the new directory and update some file permissions:
    cd rtl8821ce
    chmod +x dkms-install.sh
    chmod +x dkms-remove.sh
    
  7. Compile the driver:
    make
    sudo make install
    
  8. Install the driver:
    sudo ./dkms-install.sh
    
  9. Reboot

Once this is done, you will have a fully operational wireless network adapter.

Alternatively, installing eOS6 will have support right out of the box 👍🏻

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.