1

I recently installed elementary OS Juno on my MacBook Pro 10,1 (Early 2013), dualbooting with MacOS. After initially not having any wifi at all after installation, I followed the instructions here which I usually do when installing new distros and successfully installed firmware-b43-installer.

However, I cannot detect any 5 GHz networks, only 2.4 GHz ones, despite having a compatible wifi card. 5 GHz networks are detected on MacOS, and were also detected on Ubuntu 18.10 which I used before installing elementary OS. I also updated the kernel to 4.19.66-041966-generic using UKUU. I also set /etc/default/crda to my country code which was suggested somewhere.

Some additional information about my system:

lspci -nn -d 14e4:

04:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4331 802.11a/b/g/n [14e4:4331] (rev 02)

iwlist chan:

lo        no frequency information.

enx00e04c680a96  no frequency information.

wlp4s0b1  13 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz

I'm no expert but as far as I understand it, iwlist chan suggests the wifi card does not support 5 GHz (?), but as I wrote above I know for a fact that it does. Is there anything I can do to fix this problem? I need to be able to use my 5 GHz network since 2.4 GHz is unacceptably slow.

Thanks a lot for any help!

0

It seems like it was a driver issue. I already tried to sudo apt purge firmware-b43-installer and sudo apt install bcmwl-kernel-source, i.e. changing the drivers, which didn't solve the issue. However, I figured something might have gone wrong so I tried it again today. Purging the drivers caused the computer to crash, but then I did a hard reboot, installed the other drivers again using a wifi dongle, and now it worked.

Oddly enough, Ubuntu 18.10 and elementary OS 5 Juno don't use the same wifi drivers. Good to remember for the future.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.