0

This question already has an answer here:

I tried to solve problem with installing vim and changed /etc/apt/sources.list . I'm using juno5. When I'm trying to update : Err:1 http://non-us.debian.org/debian-non-US stable/non-US InRelease Could not resolve 'non-us.debian.org' Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease
Get:3 http://security.debian.org stable/updates InRelease [39,1 kB]
Hit:4 http://dl.google.com/linux/chrome/deb stable Release
Hit:5 http://repo.yandex.ru/yandex-disk/deb stable InRelease
Hit:6 http://ppa.launchpad.net/atareao/telegram/ubuntu bionic InRelease
Get:7 http://security.debian.org stretch/updates InRelease [94,3 kB]
Hit:8 http://packages.elementary.io/appcenter bionic InRelease
Hit:9 http://ppa.launchpad.net/deadsnakes/ppa/ubuntu bionic InRelease
Err:3 http://security.debian.org stable/updates InRelease
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY AA8E81B4331F7F50 NO_PUBKEY 112695A0E562B32A Hit:10 http://ppa.launchpad.net/elementary-os/stable/ubuntu bionic InRelease
Hit:12 http://ppa.launchpad.net/gezakovacs/ppa/ubuntu bionic InRelease
Hit:13 https://download.sublimetext.com apt/stable/ InRelease
Hit:14 http://ppa.launchpad.net/git-core/ppa/ubuntu bionic InRelease
Hit:15 http://ppa.launchpad.net/maarten-fonville/android-studio/ubuntu bionic InRelease
Hit:16 http://ppa.launchpad.net/elementary-os/os-patches/ubuntu bionic InRelease
Hit:17 http://ppa.launchpad.net/philip.scott/elementary-tweaks/ubuntu bionic InRelease
Err:7 http://security.debian.org stretch/updates InRelease
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9D6D8F6BC857C906 NO_PUBKEY AA8E81B4331F7F50 Hit:18 http://ppa.launchpad.net/slytomcat/ppa/ubuntu bionic InRelease
Hit:19 http://ppa.launchpad.net/webupd8team/atom/ubuntu bionic InRelease
Hit:20 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease
Ign:21 http://http.us.debian.org/debian stable InRelease
Get:22 http://http.us.debian.org/debian stable Release [115 kB]
Get:23 http://http.us.debian.org/debian stable Release.gpg [3 133 B] Ign:23 http://http.us.debian.org/debian stable Release.gpg Reading package lists... Done
W: GPG error: http://security.debian.org stable/updates InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY AA8E81B4331F7F50 NO_PUBKEY 112695A0E562B32A E: The repository 'http://security.debian.org stable/updates InRelease' is not signed. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details. W: GPG error: http://security.debian.org stretch/updates InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9D6D8F6BC857C906 NO_PUBKEY AA8E81B4331F7F50 E: The repository 'http://security.debian.org stretch/updates InRelease' is not signed. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details. W: GPG error: http://http.us.debian.org/debian stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 04EE7237B7D453EC NO_PUBKEY 648ACFD622F3D138 NO_PUBKEY EF0F382A1A7B6500 NO_PUBKEY DCC9EFBF77E11517 E: The repository 'http://http.us.debian.org/debian stable Release' is not signed. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details.
My /etc/apt/sources.list: `

 deb http://non-us.debian.org/debian-non-US stable/non-US main contrib 
 non-free
 deb http://security.debian.org stable/updates main contrib non-free

 deb-src http://http.us.debian.org/debian stable main contrib non-free
 deb-src http://non-us.debian.org/debian-non-US stable/non-US main 
 contrib non-free
 deb http://security.debian.org/ stretch/updates main contrib non-free`

marked as duplicate by Lewis Goddard Aug 7 at 15:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • This is a place for questions about elementary OS, not any other OS. That said, this answer should help you: askubuntu.com/a/15272 – Lewis Goddard Jul 31 at 17:14
  • @LewisGoddard, I wrote that I'm using eos juno, what's wrong? Link that you shared doesn't work for me – Andrey Orel Aug 1 at 13:30