0

Hello I just installed Elementary OS 5.0 Juno. After the installation, from the app center I installed NVidia 3.40 and then clicked to install NVidia 390. Later I realized I can only used either 3.40 or 3.90, so I clicked to install 3.40 again, but it gave me errors and stuff.
Thinking it's because of the 3.90 driver installed, I click to uninstall NVidia Drive 3.90 from the app center, but nothing happens.
I restart my PC and when I load Elementary OS it goes black screen. So I guess I messed up something in the graphical drivers.

I tried to use sudo apt --fix-broken install and it gives me some kind of errors I don't know how to fix. enter image description here

I tried to purge NVidia packages also. And hoping to install but I still get the errors while installing enter image description here

0

If your elementary OS installation is fresh and hasn't been meticulously fine-tuned for many hours, I'd suggest reinstalling it; this could really be a much quicker and cleaner solution than trying to unscramble messed video driver dependencies.

After the clean elementary OS re-installation, I'd also suggest installing the correct driver for your video card from NVIDIA PPA instead of using the default driver that ships with the system.

  • To allow installing from PPAs, execute sudo apt install software-properties-common
  • To define the correct driver version for your NVIDIA card, go here.
  • To install the driver from NVIDIA PPA, see this answer.
  • Your answer is good but, it's bad advice to install a PPA when you don't really need it. The drivers available on Appcenter are good enough and for most hardware it won't make a difference to install an older version instead of the cutting edge one. Plus a newbie would probably prefer to just do sudo ubuntu-drivers autoinstall than going into all that trouble. – Maccer Aug 4 at 19:08
  • 1
    Well, what can I say? Not so long ago my own PC couldn't work normally with 'good enough' drivers from elementary AppCenter. So I tried this method being a newbie myself, and it made my elementary installation finally work. As to adding PPAs, as far as I know, NVIDIA's PPA isn't some random piece of junk and is trusted enough. – a-tokarev Aug 4 at 20:26
  • That may be because you have new hardware or your specific hardware had an issue resolved on newer versions of the driver. But it's not typically needed. – Maccer Aug 5 at 8:09
  • Typical or atypical, thing is, it worked in real life. Thanks for downgrading. – a-tokarev Aug 5 at 10:44
0

NOTE: The following may delete apps or change settings of programs that you've already installed. Make sure to have a backup of the important files. Open a Terminal and execute the following:

First delete all nvidia drivers with sudo apt autoremove nvidia*

Then install the correct driver for your system with sudo ubuntu-drivers autoinstall


If any of this breaks your desktop, you can install it with sudo apt install elementary-desktop

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.