After installing elementary OS at the end I got an error.

My laptop originally had dual-boot with windows 8 and Ubuntu 14.04. I decided to replace Ubuntu 14.04 with elementary OS Freya, so I cleared the partition where ubuntu was installed using gparted and upon installing I chose the option which allows to install alongside windows.

After installation was completed I got a prompt:

the grub-pc package failed to install into /target

Then it allowed me to select different partitions, but still failed to install. So continued without installing grub. After rebooting, I get a prompt:

grub >

This is currently what my partitions are after installing: /dev/sda11 is where elementary OS is installed. enter image description here

Using super grub2 disk when in my cdrom and choosing the partition confirms that I elementary OS was installed and can be run.

The problem I am having with is with grub.


After trying boot-repair, here is the bootinfo summary: http://paste.ubuntu.com/12365516/

Edit In the grub prompt if I enter

set root=(hd0,gpt11) set proxy=(hd0,gpt11)/boot/grub insmod normal normal

it takes me to the grub menu where I can select elementary OS or windows and selecting elementary OS boots the operating system.

I followed the post on the question here https://askubuntu.com/questions/192621/grub-rescue-prompt-repair-grub

Tried following most of the solutions except the one involving boot-repair. But none worked for me.

  • There might be problems with secure boot if you have it. I sure faced the same trouble once. Try disabling secure boot.
    – shyam
    Sep 12, 2015 at 10:39
  • @shyam : Thanks I'll try disabling secure boot. Also Please my edit; I included a paste from bootinfo using boot-repair
    – lozadaOmr
    Sep 12, 2015 at 11:41
  • @PNG : not really sure if a duplicate. But I am currently not experiencing the error shown in the link you included. But I did end up on the same grub screen when trying to boot.
    – lozadaOmr
    Sep 12, 2015 at 14:33
  • You can't boot a UEFI system with grub-pc. Try installing elementary OS connected to Internet, in order the installer can load grub-efi.
    – bitseater
    Sep 12, 2015 at 19:55
  • @bitseater thanks, will try installing elementary OS again with a more stable internet connection.
    – lozadaOmr
    Sep 13, 2015 at 14:02

2 Answers 2


Check out the comments section of this bug thread. Freya has a know UEFI boot bug. Be sure to use your root partition as you are forcing the GRUB to load the file from the install.

  • Following the thread and using boot-repair fixed it for me
    – lozadaOmr
    Sep 14, 2015 at 9:12

I also had this problem ('grub-efi' package failed to install into /target/) and I fixed according to this askbuntu post.

Basically, what you have to do is use the option to "connect to Internet" during the Install process. It is not necessary to choose "download updates during install", just connect to Internet is enough.

  • Thanks for the answer. I believe being connected to the internet will fix the grub-efi package failed to install into /target but for me did not solve the grub > prompt.
    – lozadaOmr
    Sep 16, 2015 at 1:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.