I swear there is a way to make the icons magnify like on a mac osx when you mouse hovers over them (I don't know what I did but i had this effect until recently I updated plank and it's gone).

I am currently on a Elementary OS Freya

  • The magnify effect looks so ugly, it looks like some old cheap animation... – JulianLai Sep 12 '15 at 4:29
  • 3
    @JulianLai Try to keep comments constructive and critical, opinions are better served in chat. – Lewis Goddard Sep 12 '15 at 19:14

elementary is unable to ship a version of Plank with this code because of the Apple software patents. The version we ship has the feature patched out to avoid litigation.

You can get the upstream version of Plank from Rico's PPA

  • isn't magnifying just zoom? and isn't that enabled in ~/.config/plank/dock1/settings with #Whether the dock will zoom when hovered. ZoomEnabled=true? – user170 Mar 15 '16 at 15:46
  • 1
    @cipricus I just confirmed with Rico that the feature is not present in Freya, but also that the patch hasn't yet been applied in Loki. In other words, you're not using a released version of elementary OS if this setting is present and working for you. – Daniel Foré Mar 15 '16 at 18:06
  • I must have had some problems with sources and cleaned all the PPAs, while this build of Plank was already installed :) – user170 Mar 15 '16 at 19:53
  • Is there any way I can enable the magnifying effect in loki 0.4.1? – Shrukul Habib May 27 '17 at 17:44
sudo add-apt-repository ppa:ricotz/docky
sudo apt update
sudo apt install --reinstall plank
killall plank
plank --preferences
  • 1
    While this may answer the question, it's better if you actually say what these commands do. – RolandiXor Oct 26 '17 at 21:26
  • It's Rico's PPA mentioned by Daniel Foré in his answer – user170 Oct 28 '17 at 13:56
  • Works like a charm. Thank you. – Benjamin Jul 7 '19 at 22:30

It seems you need indeed the build provided by the PPA mentioned in the main answer. After that it is simple to make the icons magnify [...] when your mouse hovers over them

enter image description here

gedit ~/.config/plank/dock1/settings 

Change like so:

#Whether the dock will zoom when hovered. 

The zoom level is set here:

#The dock's icon-zoom (in percent).

I see this when I check Synaptic:

enter image description here

  • Manjaro OS doesn't have this feature. Ophius's answer worked for me. – Prajwal Dhatwalia Nov 26 '18 at 5:02
  • @PrajwalDhatwalia - this site and all posts here cover exclusevely elementary OS. If you are looking for posts concerning Manjaro on stackexhange, try unix.stackexchange.com – user170 Nov 26 '18 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.