1

Does anyone know how to set a default application that does not appear in the drop-down menu? I use Guayadeque as my music player but it does not appear as an option in the drop-down menu?https://i.sstatic.net/WHMIg.jpgimage

2 Answers 2

0

As far as I know, if your app isn't shown in one of these drop-downs, it means that the app hasn't been properly registered in your system. You have to register your app in the system and create a [your-app-name].desktop file (those usually reside in /usr/share/applications or /local/share/applications directories).

A .desktop file is actually a text file, so you can open and edit it in any text editor. Among other things, a .desktop file should contain a Categories line, which states the category of the app (one or several), which helps the system to properly categorize the app. For instance, for a music player this line usually looks like this:

Categories=Audio;Music;Player;

If Guayadeque already has a .desktop file, please check if it contains the Categories line.

On how to register apps and create .desktop files in Ubuntu you can refer to this tutorial.

0

In the elementary os AppCenter, there are two apps (i have installed) that can do that. They are: AppEditor and Menu editor. I recommend AppEditor over Menu Editor, because it lets you change app icons and the like. To give it the icon in the menu, turn on the show hidden entries button. then, in the search bar, search for the app.

https://i.sstatic.net/SqkLv.png enter image description here

Don't forget to make sure it has the proper category though (music player) or you will have to edit the desktop file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.