0

So, I am trying to configure my nvidia driver, installed via AppCenter, and it's not been listed in Nvidia X Server Settings as you can see here:

enter image description here

And i'm getting this error when I launch it by the console:

enter image description here

I've already did some search and tried to reinstall the driver from ppa, from .run downloaded from nvidia website and from cli 'sudo ubuntu-drivers autoinstall', but all i get is the same case. I even reinstalled the elementary itself, but nothing changes, can someone please help me? If there's any issue in my request, please tell me so I can clarify myself, thanks.

EDIT:

So, I thought it might help if I said what I'm trying to do here..

I'm looking to play CS:GO, and I just moved to Linux, on Windows, I got about 80 fps with everything in medium/high, and on Linux, I got about 40 fps with every video option in very low/low, i think it's because the GPU was in 'performance mode' on windows, set by nvidia control panel, and by what I've found on foruns, the nvidia x server settings is suppose to allow me to do that.

I don't know if that info is usefull, but it's better than none information hehehe.

  • What's your video card model? – a-tokarev Jun 23 at 8:53
  • Nvidia GeForce 930MX – Lucas Zorzi Jun 23 at 15:27
0

If your Terminal displays errors communicating with your display, please check two things.

  1. Go to System Settings > Displays and check if your display has been correctly detected by the system.

  2. Type in terminal: nvidia-smi

Are the driver version and GPU model shown in the output table? If not, try this procedure to reinstall the driver (worked fine for my NVIDIA card):

1) Clean the system from any NVIDIA drivers:

sudo apt-get purge nvidia*

2) Add NVIDIA PPA (if you haven't already added it earlier):

sudo add-apt-repository ppa:graphics-drivers

sudo apt-get update

3) Install the correct NVIDIA GPU driver and reboot:

sudo apt-get install nvidia-driver430

(this is the correct driver version for your 930MX GPU, as stated here)

sudo reboot

5) Check if the driver has been successfully installed:

nvidia-smi

6) Check if your system is free from the obsolete open-source "nouveau" driver:

lsmod | grep nouveau

If the output is negative for nouveau, then all is well with your installation.

  • So, i did the steps to reinstall the driver and looks like it's installed, but, when I typed nvidia-smi on terminal, i got this output "NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running." (same output before reinstall)... And now nvidia x server settings is completely blank, it doesn't have even the two options that was there before... – Lucas Zorzi Jun 24 at 22:36
  • PS. When I start nvidia x server settings typing on terminal "nvidia-settings", I'm getting this message: ERROR: NVIDIA driver is not loaded ERROR: Unable to load info from any available system (nvidia-settings:1666): GLib-GObject-CRITICAL **: 19:48:44.240: g_object_unref: assertion 'G_IS_OBJECT (object)' failed ** Message: 19:48:44.242: PRIME: No offloading required. Abort ** Message: 19:48:44.242: PRIME: is it supported? no – Lucas Zorzi Jun 25 at 1:14
  • If you get the error message "NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver", try disabling Secure Boot Control in BIOS. – a-tokarev Jun 25 at 6:45
  • IT WORKED!!!! FINALLY!!! Before creating this post i did a lot of search, to see if i could do it by myself, but i didn't find anything about the secure boot, i would never think about it, so, thank you soooooo much for all your help, you really saved me... – Lucas Zorzi Jun 25 at 22:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.