I click the download button, then i can see the page with message like this "Unable to access the site. Connection reset".

No matter if i'm trying on the different computers or the different browsers (Chrome, Firefox, Safari).

At the same time i can load other Linux systems, for example Manjaro or Endless OS. This problem only with eOS ;( What can i do? Thx for attention.


Do you use any kind of adblocker, NoScript, etc? The Purchase/Download button seems to have something to do with Stripe.com (online payment service). So I guess, you have to let it execute its scripts to download the iso.

Here's the official magnet link to official elementary .iso. (You can also donate "what you want" amount to the devs, of course.)


I know there was some problems with the download servers some time ago, but i did think they where fixed, I know this is going to sound strange but have you tried turning your computer off and back on again, also turn your router off and back on. I had a problem some time age where i could not get onto some web sites and i did a router reset and all worked after that.

Hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.