Elementary OS seems to support almost everything on the Asus TP200S out of the box, but one issue is screen auto-rotation.

Elementary OS recognises that the screen should be rotated when flipping the computer into tablet mode and back, but by default the screen is rotated sideways 180 degrees when in laptop mode. In tablet mode, the screen flips to landscape, horizontal mode (what I want in laptop mode).

Changing the GUI settings allows me to change the rotation manually. However, if I put the screen into horizontal/landscape mode, it will not switch to vertical mode when I flip it into tablet mode, even though I have rotation lock off.

Furthermore, the GUI settings never persist in the lockscreen. No configuration of the GUI rotation settings shows up in the lockscreen and it's always rotated 180 degrees in laptop mode (but it will flip into landscape/horizontal mode when I put it into tablet mode in the lockscreen).

2 Answers 2



This was an issue with iio-sensor-proxy. Running "monitor-sensor" in terminal showed an incorrect orientation, so I knew the problem was with iio-sensor-proxy and not with Elementary OS.

Sudo all steps.

Navigate to /lib/udev/hwdb.d and open 60-sensor.hwdb with a text editor. Scroll down to where you start seeing entries that look like the following


ACCEL_MOUNT_MATRIX=-1, 0, 0; 0, 1, 0; 0, 0, 1

Copy the entry that most closely resembles your make and model of computer, and paste it into a new file in the same folder (/lib/udev/hwdb.d/) called 61-sensor-local.hwdb.

Replace the model and manufacturer with your model and manufacturer, and change the values in ACCEL_MOUNT_MATRIX. Each axis, x-y-z, separated by a semicolon, can only have one non-zero number and it must be 1 or -1. Experiment with different values until you find what works. It's a pain because you have to reboot each time. Use the following two links as guides.



Note, I said copy and paste the entry from 60-sensors.hwdb and replace the names instead of writing it from scratch because if you follow verbatim the instructions in the two links, you'll notice the asterisks are in different spots. It didn't work for me unless I mimicked exactly what was already in the config file.

Make sure you update your system using the commands in the aixin.fr link.


You can disable the rotation sensor with the following commands:

sudo systemctl stop iio-sensor-proxy.service

sudo systemctl disable iio-sensor-proxy.service


sudo apt-get remove iio-sensor-proxy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.