0

I want to update the repositories and I see these commands.

dpkg: error al procesar el paquete grub-pc (--configure):
 instalado grub-pc paquete post-installation guión el subproceso devolvió un error con estado de salida 128
dpkg: problemas de dependencias impiden la configuración de grub-efi-amd64-signed:
 grub-efi-amd64-signed depende de grub-efi-amd64 | grub-pc; sin embargo:
  El paquete `grub-efi-amd64' no está instalado.
 El paquete `grub-pc' no está configurado todavía.

dpkg: error al procesar el paquete grub-efi-amd64-signed (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de grub-gfxpayload-lists:
 grub-gfxpayload-lists depende de grub-pc (>= 1.99~20101210-1ubuntu2); sin embargo:
 El paquete `grub-pc' no está configurado todavía.

dpkg: error al procesar el paquete grub-gfxpayload-lists (--configure):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para libc-bin (2.27-3ubuntu1) ...
Se encontraron errores al procesar:
 grub-pc
 grub-efi-amd64-signed
 grub-gfxpayload-lists
E: Sub-process /usr/bin/dpkg returned an error code (1)

What I do??

  • Please do not mind me asking, can you change your language to English for a moment and try doing what you want to do in terminal? This way generated error will be in English. – Hasan Jun 4 at 6:29
0

I want to update the repositories and I see these commands.

Setting up grub-pc (2.02-2ubuntu8.13+elementary8~ubuntu5.0.1) ... dpkg: error processing package grub-pc (--configure): installed grub-pc package post-installation script subprocess returned error exit status 128 dpkg: dependency problems prevent configuration of grub-efi-amd64-signed: grub-efi-amd64-signed depends on grub-efi-amd64 | grub-pc; however: Package grub-efi-amd64 is not installed. Package grub-pc is not configured yet.

dpkg: error processing package grub-efi-amd64-signed (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: grub-pc grub-efi-amd64-signed E: Sub-process /usr/bin/dpkg returned an error code (1)

What I do?

  • Your machine says "Package grub-efi-amd64 is not installed" (and probably therefore "grub-pc is not configured yet"). Have you tried to install this package? – a-tokarev Jul 7 at 7:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.