2

I've tried to install hplip-3.15.7.run which I downloaded from hplipopensource. When I run the file, I always get stuck on the missing required dependencies as below. It does not give specific dependencies that I need to install.

MISSING DEPENDENCIES

Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed. Package-Name Component Required/Optional libnetsnmp-devel network REQUIRED
sane-devel scan REQUIRED xsane
scan OPTIONAL gcc base
REQUIRED dbus fax
REQUIRED

2

You will find the dependency list for HPLIP here:

HPLIP Dependency List

Here's a blog showing guidelines on installing HPLIP and it's dependencies on elementary:

HP Printer Setup Under Elementary OS

And here is a similar question like yours which says, if you are using elementary 0.3.1, you need to choose ubuntu 15.04 in the download area of the HPLIP website.

Install New Version Of HPLIP

  • Finally a guide that solved my problem. Thanks you sir @godslayer – Frozzbyte Sep 10 '15 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.