0

I occasionally attempt to use Super+P as a keyboard shortcut for an app I use on Elementary, and instead it triggers the Cycle Display Modes action, which resets my monitor layout.

Is there a way to change this hotkey to something else? It doesn't appear to be in the keyboard settings, and I can't find it through the dconf-editor either.

0

If I'm not wrong, you can change any system shortcuts by using the System Settings > Keyboard > Shortcuts. For some reason I can't find there Super+P, but I can recommend you to try to reassign it to some Disabled shortcut - you will be asked if you are sure to do that, 'cause it is already reserve so you have to confirm the change and this way it will be released by Cycle display layout. After this you can set the one you just changed again to 'Disabled' (click on it and press enter) and based on my experience (checked again just now) it will not be reassigned to 'Cycle displays'.

| improve this answer | |
  • Unfortunately, I've tried this. I've tried setting "Home Folder" and even some workspace options to Super+P and it doesn't prompt me for conflict. Do you know which shortcuts you tried? – R.J. Lorimer Jun 4 '19 at 2:07
  • Hmm.. I have tried to reassign the Super+F to Toggle Fullscreen mode and I did it successfully because I don't see any aim to have this Picture in Picture mode functionality but I use fullscreen a lot. Now I just tried to assign Super+P to Toggle on all workspaces and it works. The system did not prompt me, probably because the moment I did this I was with single monitor. I have connected the second one and pressing Super+P do not Cycle display layout anymore, but the function key for that on my laptop doesn't cycle display layouts neigther .. – Bo rislav Jun 4 '19 at 4:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.