I'm wondering if I can get some guidance on how elementary manages audio devices -- especially how it detects them. Do you use Pulse or ALSA? Is there potentially a package missing?

In my situation, I'm seeing...

No Output Device There is no output device detected. You may want to add one to start listening to anything.

...in System Settings --> Sound. However, aplay -l shows two Intel HDA cards, and vlc is able to play directly to the audio devices, so I know for sure the hardware is not an issue.


I ran io.elementary.switchboard from the terminal with G_MESSAGES_DEBUG set to all, and found a message like pa_context_connect () failed: Connection refused.

1 Answer 1


I have solved this issue for me. The permissions in the home folder were very strange -- root:root and 777. I changed them to the my user and 755 for directories, 644 for files, and all works now. If you're running into this and you don't have messed up permissions in your home folder, I recommend you check the solutions in this thread for more information.

  • Permissions for what file(s)?
    – EEE
    Commented Dec 15, 2020 at 21:36
  • If I recall correctly it was the whole home directory. Commented Apr 2, 2021 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.