1

I'm testing out Elementary OS as a gaming desktop distro and I think an Xbox Elite controller may be causing the OS to completely crash and make the mouse and keyboard AND my Razer Orbweaver (small gaming keyboard) completely unresponsive.

The only fix is to hard reset my PC using the reset button. Obviously not ideal.

How can I troubleshoot this?

Reason I believe the controller is causing the issues:

On two occasions the OS became completely unresponsive the instant I plugged in the controller.

I managed to get it working by having it plugged in already and THEN turning the PC on. Played Mad Max on Steam and it worked great.

Then this morning I woke up my PC from sleep and it was crashed on the greeting screen and was unresponsive.

I noticed the LED's on my mouse and keyboard went out as well indicating that perhaps it wasn't even the OS that was unresponsive, but instead the USB ports completely failing.

Controller is being plugged into the front port, other peripherals are in the back.

I don't have any high draw devices such as HDD's plugged into USB and I've never had issues in Windows 10.

Also, I tried unplugging my mouse and keyboard and plugging back in after they were unresponsive and this didn't help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.