2

Previous to Juno, my retina 13 got some liquid spilled. I cleaned it then the service said they didn't know how to fix it - it boots only in safe mode on osx.

So I installed Juno , (I manage to enter GUI via grub cmdline option nomodeset. If I remove it - I have graphics artefacts and it's unusable)

inxi says:

Device-1: Intel 3rd Gen Core processor Graphics driver: N/A
Display: x11 server: X.Org 1.19.6 driver: fbdev,intel unloaded: modesetting,vesa
resolution: 2560x1600~93Hz
OpenGL: renderer: llvmpipe (LLVM 8.0 256 bits) v: 3.3 Mesa 19.0.2

So I guess it's running a non-accelerated framebuffer driver, I have only 1 resolution (2560x1600), pixel doubled (1280x800) or not, no brightness control. Fullhd works acceptably well although high cpu on Chrome.

I tried adding some other resolutions via cvt and xrandr add mode/new mode, also xorg.conf, but once I switch to them nothing happens.

Here is the output of xrandr:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 2560 x 1600, current 2560 x 1600, maximum 2560 x 1600
default connected primary 2560x1600+0+0 0mm x 0mm
2560x1600 93.00*

if I enable modesetting driver it's unusable, lots of artefacts and it crashes - I enabled it via xorg.conf file by specifying driver "modesetting" - system is up to date.

I also installed the intel driver via Device Driver Manager app from Linux Mint but it appears X crashes (not sure here)

The question is how can I add some other resolution and go about the brightness control via fbdev driver or other options to make the best use of this laptop (as I can't use it anymore under OSX apparently)

Thanks in advance and nice distro.

Some other details: My xorg.0.log file (graphic related stuff) :

Link

My xorg conf file situated in /etc/X11/xorg.conf.d/20-intel.conf (Although I don't think it affects anything) : Link

[EDIT]: Also tried installing an updated driver via http://ubuntuhandbook.org/index.php/2019/01/install-mesa-18-2-8-ppa-ubuntu-18-04-18-10/ but it's unusable (black screen with artifacts). I think it is a hardware problem but how do I go around it, namely to have multiple resolutions + brightness adjust, even with the fbdev driver if no other options?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.