1

From the Juno, elementary support iBus as a default input-method-framework. Thus, someone who want to type in Hangul(Korean Alphabet) in Juno and using Korean locale(Asia/Seoul with Korean 101/104 keyboard layout). You should use ibus-hangul which would be installed while installing Juno. In that case, you shoud do this after the installation.

* system settings - keyboard - Input Method settings
* delete english keyboard layout (since the bug of ibus) 

enter image description here

And you need to know as well, there might be an issue with inputting Hangul in some online service and apps like Facebook, and some development tools while using ibus-hangul. I would recommend to you to use nimf as your Hangul input method for Korean.

sudo apt install software-properties-common
sudo apt-add-repository ppa:hodong/nimf
sudo apt update
sudo apt install nimf nimf-libhangul
im-config -n nimf
Logout & Login
nimf-settings

But, If you are in other locale , it might not be installed by default. In that case, you should install ibus-hangul manually.

sudo apt install ibus-hangul
im-config -n ibus-hangul
logout & login

or it might be better to use nimf as your input method like Korean.

elementary OS team needed to implement input method for universial users, so they load iBus as a default input-method-framework for those universial users like Korean, Japanese, Chinese and more...

This guide is for the people who want to input Hangul(Korean Alphabet) but might help for other input methods user as well, I hope so.

Thank you for reading it.

1
  • Thank you for adding this useful information. However, I suggest you add this proper way - ask a question and add how to do it in and as answer. You can edit this one. No need to create another. – Hasan May 14 '19 at 14:11
0

Since this is the first result when searching for "korean keyboard elemntary os", I would like to add this answer, as Hasan commented, as well as for my own future reference.

My use case is: I have a US QWERTY keyboard using elementary OS 5.1.7 Hera and I want to type in 한굴.

  1. Go to Keyboard Settings (CMD + SPACE + keyboard) Search Keyboard Settings

  2. Go to "Input Method" tab (enable it if not yet enabled) and click the bottom left plus (+) sign and type "hangul" then click "Add Engine" Add hangul as input method

  3. Configure input method to use ibus by default (see also https://elementaryos.stackexchange.com/a/18660)

# open terminal (CMD + t)
im-config

# in GUI
# click Ok
# click Yes
# select ibus
# click Ok
# click Ok

reboot
  1. Try typing in 한굴 by toggling via the Right Alt key. If that doesn't work try Shift + Space.

(I found out about the right alt key in the Layout tab of the keyboard settings, there is no need to set Korean keyboard in Layout, just in Input Method).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.