When booting my Dell XPS 15 if I do not manually boot to the "Ubuntu" device by pressing F12 and selecting "Ubuntu" my computer automatically goes into diagnostics mode and runs tests on memory, screen, etc.

I have a feeling this may have to do with Secure boot or UEFI mode, not sure though.

Happy to provide any information that is necessary.

2 Answers 2


I had this issue with my XPS 13 9730. It's due to UEFI boot being set in BIOS. You need to enable Legacy Boot. I'm trying to work out how to force Elementary OS to install as UEFI because Legacy is much slower.


As far as I know, UEFI installation needs a partition that contains some configuration files for your BIOS. It should warn you when installing the OS. I don't know what the flag is but it has something saying uefi_boot. Something like that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.