0

Whenever my computer sleeps or hibernates, I am unable to fully wake it up. Sure, the system seems to be running and all, but the display never returns. Just stuck with a black screen.

Currently, I am working around the issue by disabling suspend via "systemctl mask" and masked all forms of hiberate and sleep. So now the system will never sleep and display remains active. Setting hibernate time to 'never' in system settings does nothing, hence the 'mask' workaround.

Does anyone know a solution to this, so I can hibernate and resume properly?

About my system: ASRock B450M PRO4; Quad-Core AMD Ryzen 5 2400G with Radeon Vega Graphics; elementary OS 5.0 Juno

  • And this is happening in a fresh installation? – Hasan Apr 27 at 15:22
  • Yes. Tried reinstalling twice. And then searched for drivers. But still problem persists – Lucian Apr 27 at 19:43
  • Can you please check here? Create a new issue if you want describing your situation. – Hasan Apr 28 at 5:03
  • Same issue. Close lid, sleep or lock leads to blinking black screen. Also cannot get to another tty. (Dell Inspirion 7537, Elementary Juno) – Jiří Juřica May 24 at 20:05
  • I'm having the same issue on a Dell precision 5530. When i close the lid or use suspend or hibernate, after the pc wakes up i get a black screen that sometimes blinks. I have installed the drivers for my nviday GPU but no changes. I upgrade my kernel to 5.0.16 but still no changes. – Thomas Vanhoutte Jun 5 at 9:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.