0

Having issues with getting the Calendar app to read my CalDav from a nextcloud instance, after adding and typing password, it just does not appear.

I looked through the net and tried all the options I could find regarding this issue and change the CalDav site to million different options.

Any ideas what could be an issue or how the url should be formatted?

  • Can you please add the options in your question with the process as you tried? It will help others understand your situation better. And if you have solved your issue already, consider adding an answer describing how you achieved it. – Hasan Apr 29 '19 at 17:53
1

To solve this issue install Evolution from AppCenter and add your CalDAV there. Then the elementaryOS Calendar will start working.

It's an old issue.

| improve this answer | |
0

I've encountered the same problem and fixed it by specifying a direct calendar endpoint. This does not require the installation of any additional software or settings.

The two endpoints automatically generated through the online Nextcloud Settings function within the Calendar app are in the following format:

  • https://example.nextcloud.com/remote.php/dav
  • https://example.nextcloud.com/remote.php/dav/principals/users/USERNAME

Currently, these do not work with the elementary OS calendar app.

To correctly load your calendars, you must copy the private link generated by opening the drop down menu beside each calendar and clicking Copy private link. This will give you the following endpoint format:

  • https://example.nextcloud.com/remote.php/dav/calendars/users/USERNAME/personal/

Tested to be working on: elementary OS 5.1.7 Hera with Nextcloud 19.0.5

Caveat: each calendar has to be added manually

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.