0

Reposting here from reddit Hi everyone, Noobity McNooberson here.

So, next semester I'm supposed to start a programming class and I'm very excited for it, so I thought I would install a linux based os on my ASUS N550JV (came with W8, updated to W10) in dual boot (still need W10 for adobe), just to get the hang of it (I was told from another student that the teacher would require us to have some sort of linux os for class purposes and that linux-based os do not make your pc sound like an airplane taking off, bc they're lighter)

So, I took the distro picker test and eOS Juno scored the highest for my necessities (also is sooo cute)... But I'm such a noob, that I can't even get it to work! :(

I've spent the last two days trying to work around it, and this is what keeps on happening:

  • I make a USB bootable with Rufus

  • I go in UEFI mode: in Security, I disabled the Secure Boot Control, in Boot I enabled both Launch CSM and Launch PXE OpRom, then Save&Exit

  • During the reboot, I remove the live USB, no error (I assume I did it correctly)

  • After the reboot, the installation goes fine

  • Reboots again and it goes straight to W10 (often altering the hour, showing 2 hours less i.e. if it's 10:30, it'll show 08:30 after reboot)

  • I go once again in UEFI > Boot, to up the partition where Elementary should be installed (it shows a new boot option called P2:something) as the first boot option and W10 as the second boot option, then Save&Exit

  • Reboots and gives this error:"Reboot and select proper boot device or insert boot media in selected boot device and press a key"

With a little intuition and research, I found out the error means that the selected partition doesn't have a OS in it.

Tried installing third party grub-fix-stuff in live mode (I didn't quite understand what I was doing, just tried to follow tutorials bc I'm a noob), but couldn't unlock ppa (whatever it is).

Tried eliminating partitions, giving the space back to the D: partition and installing again, didn't work.

Tried cleaning and recreating the USB bootable and going to the whole process again, didn't work.

Could you please help me understand what's going on?

ps: again, I'm very noob so pls don't hate

pps: also, I'm european, english is not my first language so, I hope I'm not coming off as a pretentious asshole, I really don't expect assistance from anyone, I'm just trying to understand how to solve the issue and be able to run eOS Juno and I would love to hear from more experienced ppl. Also, if you think that eOS Juno isn't the best Linux OS for my purposes or have any type of advice on the matter, I will absolutely love to hear from you!

bumped to the homepage by Community 12 hours ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

0

After reading this I think the issue is that one of the two OS isn't installed in UEFI mode or you have some incorrect setting in the bios.

Try disabling Launch CSM and Launch PXE since you've already installed elementary you shouldn't need those enabled I think.

Also you can boot into Windows and check the boot mode pressing Win+R then typing msinfo32 and looking for the words BIOS Mode.


Source

  • I tried disabling Launch CSM and Launch PXE, but it booted straight into W10, but taking a little longer than with both settings enabled (not sure if it's relevant). Tried the second and the BIOS mode is UEFI. – rosenrot Apr 22 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.