0

Have installed Elementary OS per the official instructions, and it never shows GRUB but rather boots straight into Windows. Here's a non-exhaustive list of what I've tried so far:

  1. Turn off quick boot & disable safe boot
  2. Run boot-repair (log here: http://paste.ubuntu.com/p/GtrJw76R2q)
  3. Mess with boot order
  4. Reinstall Elementary
  5. Boot in Legacy mode (shows black screen with blinking cursor forever)
  6. Use BCD edit (Elementary doesn't show up, and it gives me a warning that since my computer is booting in EFI, its functionality is limited
  7. Use command line to bypass this (bcdedit /set ...)
  8. Mounting/chrooting stuff to be able to run update-grub

Needless to say, I'm pretty frustrated at this point... I've taken a look at a bunch of the answers on here but none that I've found have worked. Help would be greatly appreciated! I'm thinking this is a more complex issue, so hopefully the boot-repair log will provide any relevant details.

0

Please follow the instruction even if you tried them before and I know how frustrating this can be. But please do follow the instruction once again. It should fix your issue.

Boot int Windows > Search for Command Prompt > right click on it and click run it as administrator > Then please execute this command bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi > Restart your computer.

  • Thanks so much, this did the trick! I did run this as administrator before, but the problem was I directed it to shimx64.efi instead of grubx64.efi. Simple mistake, thanks for the catch! – Graeme Holliday Apr 21 at 19:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.