0

I have an US layout keyboard. I like to have the umlaute like I had them in Windows (US International Layout) where ALT+P is an "ö" and so on...

I figured out when I use sudo dpkg-reconfigure keyboard-configuration that I can change to US International layout but the compose key Right Alt seems to be not working...

I also found out that every other key i use as a compose key works. Only Right Alt not.

Any ideas?

  • Please help me understand that you want to type Umlaute using the right ALT but its not serving its purpose? – Hasan Apr 19 '19 at 7:57
  • @Hasan yes I want to type Umlaute with Right Alt but Right alt is not working as compose key. – Phil Roggenbuck Apr 19 '19 at 7:59
  • Okay, but let me ask something else - In your settings what keyboard layout you have? Or do you have selected German layout as one your preferred layout? – Hasan Apr 19 '19 at 8:07
  • Please go to Settings > Keyboard > Select / Add your layout > Change Compose key and tell me if it helps. – Hasan Apr 19 '19 at 8:13
  • @Hasan unfortunately when I do this he switches back to the normal US Layout and not the International Layout. So this does not work. But thanks though. – Phil Roggenbuck Apr 19 '19 at 8:29
1

I found the solution (I did the wrong combination before):

  1. sudo dpkg-reconfigure keyboard-configuration
  2. Choose Generic 105-key PC (intl.)
  3. Choose English (US)
  4. Choose English (US) - English (intl., with AltGr dead keys)
  5. Choose Right Alt (AltGr)
  6. Choose No compose key

And that's it :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.