3

Trying to get my HP Officejet 5740 working with scanning. Everything I find is outdated or not working. When I try to run the hp-setup command, I get this below:

error: HPLIP is not installed properly or is installed without graphical support. Please reinstall HPLIP
warning: Qt/PyQt 4 initialization failed.
error: hp-setup requires GUI support (try running with --qt3). Also, try using interactive (-i) mode.

I can print to the printer, but that’s it. Can anyone help me out with this? Really need help getting scanning working.

2

This is how I installed HPLIP 3.15.11 to support a HP Color LaserJet M277n on Freya 0.3.1:

Remove old HPLIP

sudo apt-get remove hplip

Install dependencies

sudo apt-get install gcc build-essential python-dev libcups2-dev libusb-1.0-0 libtool libcupsimage2-dev libsane-dev libsnmp-dev python-qt4 python-qt4-dbus python-dev xsane

Set a root password, the installer will ask for it

sudo passwd (somepass)

Run the installer

sh hplip-3.15.11.run

Choose auto installation Distro selection: Ubuntu, 14.04

Installer defaults for everything else

Auto discovery didn't find anything, but a manual IP address selection worked fine. I was prompted to run 'hp-plugin' to install a binary plugin for this printer during the printer setup process.

Printing and scanning now both work for me.

  • Why does this require setting a root password? – embik Dec 9 '15 at 16:09
  • @embik the hplip installer specifically asks for it, and is unhappy running under sudo - more info here: hplipopensource.com/node/316 – Moby Duck Dec 9 '15 at 18:42
1

HP Officejet 5740 is working with the new HPLIP which you can get here.

http://hplipopensource.com/hplip-web/index.html

http://hplipopensource.com/hplip-web/models/officejet/officejet_5740_series.html

Don't forget to deinstall the version of hplip and hplip-gui you have already installed.

And further. If you have already installed freya 0.3.1 so you have to choose Ubuntu 15.04 in the download area on the HPLIP website.

  • I've tried already, I'm getting multiple problems. If I try to run the installer with sudo, I go through the wizard and get note: Installation of dependencies requires an active internet connection. warning: Missing REQUIRED dependency: libusb (libusb - USB library) warning: This installer cannot install 'libusb' for your distro/OS and/or version. error: Installation cannot continue without this dependency. Please manually install this dependency and re-run this installer. – user2277 Sep 8 '15 at 20:02
  • I've managed to shorten the list of missing dependencies, but unable to download these below. pyqt4,sane-devel pyqt4-dbus python-devel – user2277 Sep 8 '15 at 20:19
  • I've the same problem. I want to install an newer version of hplip because i bought a new printer. But the dependencies failed my installation every time. – Stiffler Sep 9 '15 at 11:28
  • 2
    Yup, I got the same problem about a month ago. hplip doesn't recognize that elementary OS is based upon Ubuntu, so you're going to have to install every single dependency manually to make it work. pyqt4 is actually python-qt4, pyqt4-dbus is python-qt4-dbus, python-devel is actually python-dev. So, after we combine all of that, sudo apt-get install python-qt4 python-qt4-dbus python-dev should do the trick. – r3bl Sep 9 '15 at 21:20
  • 1
    @RolandiXor This is more like a supplement to this answer than the answer itself. – r3bl Sep 10 '15 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy