1

After a new clean installation of Juno I tried to enable Night light with the automatic sunrise/sunset timing. This did not work as expected. What did happen was, that night light kicked in only at the (previously) designated manual times. You can try to switch to manual and change the times, and this setting will stick even after changeing the switch to "sunrise/sunset".

There is a similar problem with Ubuntu that I know of - if a user selects the same option in gnome-settings, but does not enable Location services (in a separate settings panel), the functionality won't work. Unfortunately enabling location services in elementary switchboard doesn't solve this issue in eOS. This should be addressed by the devs.

  • Please add the solution separately by posting it as an answer. – Hasan Apr 11 at 9:08
  • And please mark your answer as one to let others know that the answer actually solved your problem. – Hasan Apr 11 at 9:21
  • I will, but I can't at the moment - I will only get a message about having to wait for two days... – djaeris Apr 11 at 9:54
  • Yes, system requires a minimum wait time before a answer can be marked as an answer. I forgot to tell this earlier, my bad. – Hasan Apr 11 at 9:57
4

As an interim solution you can install dconf-editor and change the key org/gnome/system/location to enabled. After that, the Night light settings will work as expected.

You can also change the setting in the terminal without installing anything by executing gsettings set org.gnome.system.location enabled true

Please execute sudo apt-get install dconf-editor in the terminal to install dconf-editor. You can also find it in the AppCenter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.