Lenovo X1 Carbon internal 14" hidpi display (2560x1440) Two external Samsung 27" lodpi displays (2560x1440)

No matter if I use auto, HiDPI and LoDPI the result is that if the internal screen is used the two external displays use huge icons/fonts.

In Ubuntu I used LoDPI and set the resolution of the internal screen to 1920x1080, but in Juno the two external displays still have wrong scaling regardless of resoultion on HiDPI display.

I've seen other posts on this for Loki. But I feel that the HiDPI/LoDPI setting is ignored in Juno.

I've tried running:

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "[{'Gdk/WindowScalingFactor', <1>}]"
xrandr --output eDP-1 --mode 1920x1080  --output DP-2-1 --auto --scale 1x1 --right-of eDP-1 --output DP-2-2 --auto --scale 1x1 --right-of DP-2-1

Which gets me close, but notifications and cursor is still scaled, even if the rest is not.

Any other tips?

  • Are you attempting this on a fully updated system? There was an update to the display settings in switchboard 4 days ago that potentially resolves the issue you're referringto. Apr 9, 2019 at 15:58
  • I have the same using a Dell XPS 15" - I have Dell monitors at work and Illyama at home. I installed ARandR & saved 3 different screen configs - laptop only, work & home as shell scripts in a settings folder (~/.screensettings). By making these scripts executable (chmod +x ~/.screensettings/work.sh) I can assign keyboard shortcuts via the System Settings, Keyboard, Shortcuts. Just hit the shortcut & it's sorted. I have to run my laptop screen in LoDPI mode which is a bit of a shame, otherwise I have to continually log in and out between locations. Would love a proper fix!
    – rolandw
    Apr 9, 2019 at 17:45
  • The issue is still there on a fully updated system. Like rolandw I've created a script that runs the two commands above when I'm at work and have the two extra screens connected.
    – Paaland
    Apr 9, 2019 at 19:09


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.