1

I tried to install a NVidia driver, now nothing works. I followed this guide: http://ubuntuhandbook.org/index.php/2013/08/install-nvidia-opengl-4-4-driver-325-05-03-in-ubuntu-linux-mint/ The installation failed and now the screen is just black after the elementary logo during start up.

Anyone know what I have to do to fix it?

  • Cannot start the OS normally to reach TTY. Tried in recovery mode and followed the command to uninstall, did not work. – user2317 Sep 7 '15 at 21:14
  • Are you sure that you can't switch to TTY once you have the black screen after booting normally? Apart from that I can only recommend finding out which packages the installer provides and purging them. – Lewis Goddard Sep 8 '15 at 7:53
5

Please don't follow random internet instructions, especially when they're a couple of years old. The instructions you followed were published on August 20th, 2013. They are likely pointing to what is now an out of date driver, and will have been tested on elementary OS 0.2 Luna, since Freya wasn't released until April 2014.

Option 1: (Re-) Install Freya 0.3.1

Freya 0.3.1 was recently released with an upgraded graphics stack. Installing that and sticking to the drivers found in the "Additional Drivers" module is probably both the easiest and safest way. You should be able to access your hard drive and take off any files you want to keep.

Option 2: Purge the driver

  1. Switch to the TTY using Ctrl + Alt + F1
  2. Login with your username and password.
  3. Uninstall the driver.

The article you linked lists the uninstall command as:

sudo ~/Downloads/NVIDIA-Linux-*-325.05.03.run --uninstall
  • Lewis Goddard: Yeah, I'm sure. doesn't seem like it boots correctly. The installation logs are also no use since they've been overwritten when I've tried to fix the issue. Seems like I'll have to reinstall. Thanks for your help, I'll be more careful following random instructions in the future. – user2317 Sep 8 '15 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.