I'm on Freya 0.3.1 64bit and get the message

Gtk-Message: Failed to load module "pantheon-filechooser-module"

when running an electron shell app.

I tried to start it with

GTK_MODULES=pantheon-filechooser-module electron .

and tried to set

gsettings set org.gnome.settings-daemon.plugins.xsettings enabled-gtk-modules "['pantheon-filechooser-module']"

but neither worked.

Any chance to enable that module?

2 Answers 2


It is not possible to use the file chooser module with non-gtk3 apps. You will always see this warning message with those apps. When the module fails to load, you'll get the fallback gtk2 chooser.

  • so its expected behaviour? Commented Nov 4, 2015 at 12:44
  • @FerriSutanto that's correct Commented Nov 5, 2015 at 1:07
  • GTK_MODULES=pantheon-filechooser-module can be made to work in current eOS though.
    – dotbit
    Commented Feb 22, 2019 at 9:02

Try to remove space in 'Screenshot Monitor.exe', for example

sudo cp /usr/share/ssm/Screenshot\ Monitor.exe /usr/share/ssm/sm.exe

and then change /usr/share/applications/Screenshot\ Monitor.desktop to

Exec=mono '/usr/share/ssm/sm.exe'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.