I am admittedly relatively inexperienced in Linux so maybe I am missing something. I have gotten the wifi to work on my laptop (an HP Pavillion DM4 Beats edition) and it connects fine to something I have a password for, like my personal wifi, but when I try to connect to a WiFi hotspot it fails. I have tried this with Xfinity, Starbucks, and Books a Million ones so it is not just one provider causing trouble.

I tried a few suggested fixes found via internet searches, but the mostly didn't apply or were old enough to be no longer valid.

I did try installing net-tools and basic update of things per instructions I found online, but I can't seem to find a fix for this.

  • Still running into this problem. I have done all the updates and upgrades. I have tried adding further software tools, but nothing seems to be helping. I click connect, there are visual indications that it is trying to connect, then it fails to connect. The Wifi Security is listed as "none" as the networks are shown to be unsecured. I try to pull network info while it is trying to connect, but no ip address comes up.It works fine on normal wifi connections, but the public wifi hotspots, that redirect you to a website to finich connecting just don'tconnect. Apr 4 '19 at 17:36
  • Please update the question with the output of this - sudo lshw -C network command.
    – Hasan
    May 3 '19 at 4:36

So, this is not much of an answer, but I ran several updates of the OS, sudo apt update and sudo apt upgrade. I also the built-in updater in Elementary. I am not sure which update did it, but now I can log into wifi hot spots. My solution for other new users unclear why it isn't working is to make sure everything is up to date. The fix may already be implemented but hasn't reached you yet.

I blame linear time.

  • You installed the required wifi driver, your system did it for yourself.
    – Hasan
    May 3 '19 at 4:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.