0

whenever i try to install anything, i get that. Me and my dumb self also decided to uninstall appcenter, this is another problem im having, sudo apt-get install appcenter

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libnss-systemd : Depends: systemd (= 237-3ubuntu10.15)
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

any help appreciated.

  • The error says the solution, please execute sudo apt --fix-broken install first and then install appcenter. Let us know what you find. – Hasan Mar 16 at 17:51
  • have tried that, the output from sudo apt --fix-broken install is dpkg: error processing package libpam-runtime (--configure): package is in a very bad inconsistent state; you should reinstall it before attempting configuration Errors were encountered while processing: libpam-runtime E: Sub-process /usr/bin/dpkg returned an error code (1) – Milk Mar 17 at 4:50
1

Please execute this series of commands,

sudo apt-get autoremove

sudo apt-get --purge remove && sudo apt-get autoclean

sudo apt-get -f install

sudo apt-get update && sudo apt-get upgrade

sudo dpkg-reconfigure -a

sudo dpkg --configure -a

Above answer is grabbed from here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.