4

So I have installed Elementary OS hearing how beautiful and lightweight it is. I'll agree it is very good looking but it's too slow in my computer. I'm pretty sure I have installed all my drivers properly.

My last OS was Windows 10, it was so fast. Chrome wouldn't take more than 3 seconds to launch, but it takes atleast 20-30 seconds for Elementary OS. It takes about 3-5 minutes before a CS:GO match can start for me. Games run well though. Freezing is another problem for me. It freezes outta nowhere and it's very fraustating. I atleast need to wait a minute for that. Opening terminal is also preferably slow. I did not install Elementary OS for that. Any possible reason why is this happening and how can I solve this problem?

Specs: i3-3220, 4gb ram, R7-240, H61m Motherboard.

  • Open a terminal and execute w, then lscpu |grep "CPU MHz" and cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver. Update your question with the output. How did you install your graphics driver? What disk do you have? – Maccer Mar 15 '19 at 17:10
  • I'm facing the same problems here. Even though I have a Dell XPS13 i7, 16GB RAM. ElementaryOS 5.1 is running incredibly slow on my machine... gist.github.com/sergiomafra/8993e1fdeaab3d422de2938d06d4640f – sergiomafra Dec 11 '19 at 3:23
1

Open terminal and type:

sudo lscpi.

or

sudo update-initramfs

You probably did not install the firmware for the GPU socket and did not compiled it with the kernel above 5.5 where the issue has been solved. If you need a tutorial, let me know. I already did it and it does not freeze. By the way Elementary OS does not use prefetch directory like Windows. It does not have the fast boot solution like Windows, so do not even compare totally different systems with totally different file system and without knowledge about systemd.

Anyway the example solution which solved issue in my case:

How to upgrade Elementary OS to the newest kernel. Only for braves.

Install necessary packages
sudo apt-get install build-essential libncurses-dev bison flex libssl-dev libelf-dev
To check hardware ####
sudo lspci
to check missing firmware
sudo update-initramfs -u
Make directories for firmware
mkdir /home/username/Downloads/kernel
mkdir /home/username/Downloads/amdgpu
mkdir /home/username/Downloads/i915
mkdir /home/username/Downloads/rtl
to get rid of missing firmware errors for amdgpu
cd /home/username/Downloads/amdgpu
wget https://github.com/M-Bab/linux-kernel-amdgpu-binaries/files/4124959/firmware-radeon-ucode-rock_2.110_all.deb.zip
unzip firmware-radeon-ucode-rock_2.110_all.deb.zip
sudo dpkg -i firmware-radeon-ucode-rock_2.110_all.deb

Or use eddy to install this deb

Source: https://github.com/M-Bab/linux-kernel-amdgpu-binaries/issues/82

My comment: I was brave enough.

to get rid of missing firmware errors for i915
cd /home/username/Downloads/i915
git clone https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
sudo cp -R /linux-firmware/i915/* /lib/firmware/i915/
to get rid of missing firmware errors for rtl (Realtek LAN and Wi-Fi adapters in my DELL)
cd /home/username/Downloads/rtl
wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/rtl_nic/rtl8168fp-3.fw
wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/rtl_nic/rtl8125a-3.fw
sudo cp rtl8168fp-3.fw /lib/firmware/rtl_nic 
sudo cp rtl8125a-3.fw /lib/firmware/rtl_nic
Download kernel 5.7.0
cd /home/username/Downloads/kernel
wget https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.7.tar.xz
tar -xf linux-5.7.tar.xz
cd linux-5.7
cp -v /boot/config-$(uname -r) .config
make menuconfig 

save config and then exit.

use 4 core/thread - if your processor have 4 cores
make -j 4
or use 8 core/thread - if your processor have 8 cores
make -j 8

sudo make modules_install 
sudo make install 
sudo update-initramfs -c -k 5.7.0
ignore these errors below, just because those three bin files are not made yet
W: Possible missing firmware /lib/firmware/amdgpu/navi12_ta.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navi10_mes.bin for module amdgpu
W: Possible missing firmware /lib/firmware/amdgpu/navi12_dmcu.bin for module amdgpu

sudo update-grub
sudo reboot
uname -mrs
to check errors after reboot:
sudo journalctl -b
sudo dmesg

source: https://www.cyberciti.biz/tips/compiling-linux-kernel-26.html

| improve this answer | |
  • Example solution added. – Sysadmin Jun 10 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.