I own a HP Envy x360 15 inch and i cannot get Elementary OS Juno to install at all. I get into the menu which asks me to try it before install; Install it or install as a manufacturer. I am completely new to Linux and i wish to try eOS as windows is not interesting to me any more, i do not intend on spending 5 hours a day troubleshooting, so if that is too much to ask for, i apologize for bothering you.

After pressing either it tells me a list of sentences for 1 second and i managed to take a picture of the machines disabilities. enter image description here

  • I got it installed and it had a low resolution and unknown display, so i went to amd to get a driver for my ryzen 5 2500U and after that, the resolution went even lower. I do not even know if i managed to install it. I just pressed the install file and a yellow page popped up with a lot of text, so i assumed it had installed itself. I tried to fix the low resolution by surfing the web endlessly trying many tips, nothing helped. I then resorted to try a clean re-install of eOS, but to my surprise, the previous install apparently f***ed up my laptop so that it does not register my usb stick. I c – Runeer Mar 15 '19 at 15:25
  • press Esc or any fuction key when you boot so that you can see the firmware/bios and you can set the boot option to the usb stick. – Maccer Mar 19 '19 at 11:08

Boot your laptop, when the grub menu appears press e.

It will show a lot of text, look for the words quiet splash and add nomodeset between them. Like this: quiet nomodeset splash. Press F10 and it'll boot.

Now you need to go into AppCenter and Install the graphic driver from the Updates tab. You can also execute sudo ubuntu-drivers autoinstall if you prefer working from the terminal.

  • It worked. Thank you very much 🙏 – Runeer Mar 15 '19 at 11:35
  • Hey I've updated my question since I said something wrong. nomodeset is just for the first boot, then you need to install the driver and it will work normally on the next boot. – Maccer Mar 19 '19 at 11:07

Manually there is no drivers to be found as shown in picture. But thank you a bunch man 🙏😌

I would love for the OS to work.

My processor is Ryzen 2500u. Any hope to solve it? I do not even know how to install stuff. I have tried many guides, but it doesnt seem to work. Is it really a big process just to download and install an app from the app center? I hoped it would be a bit like android.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.