1
savageholycow@HentaiSavage:~$ sudo lshw -c network
  *-network DISABLED        
       description: Ethernet interface
       product: RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 1
       bus info: pci@0000:04:01.0
       logical name: enp4s1
       version: 10
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=off broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=64 link=no maxlatency=32 mingnt=32 multicast=yes port=MII speed=100Mbit/s
       resources: irq:18 ioport:d000(size=256) memory:f7d00000-f7d000ff

The first thing I can see here is *-network DISABLED. Is this probably the reason I can't connect to my BroadBand internet connection? I have switched from Windows 10 to Elementary OS last night. I didn't have a clue what was going on at all. Currently I am using a Mobile Broadband connection which probably won't last more than a day from now. So I really need to be able to connect to my PPPoE/Dial Up connection. Could anyone please help :(

  • Just a thought, on my work laptop there is a hard switch to turn the network on or off. You don't have that do you? – Jeff Wilson Mar 17 at 5:41
  • Has anyone found a solution to this? From my experience, when I arrive at work and replug my Lenovo T480 back in to the ethernet (as well as 2 external monitors, through the docking station) via the USB-C after having been online via wifi at home, the Wired option on the taskbar is greyed out. I open the network settings and the Wired tab says Cable unplugged. I have tried restarting the networking-manager as well as >all< the other suggestions found online for ubuntu/elementaryOs but so far the only remedy is to restart my machine. Not good enough. – Andreas Mar 18 at 9:32
0

Add a new PPPoE connection in Terminal:
nmcli con edit type pppoe con-name "pppoe"
set pppoe.username ******
set pppoe.password ******
save
quit
Then nm-connection-editor, edit ethernet/wired, General tab, uncheck "Automatically connect to this network" for the ethernet/wired connection and leave it only for the PPPoE connection.

  • Did all that but no result :( The *-network Disabled thing is still there. – Savage Mar 12 at 6:15
  • Can't turn the Wired switch on too – Savage Mar 12 at 6:15
  • Do a sudo service network-manager restart in terminal. – cristian mos Mar 12 at 7:11
  • Also, make sure that 'Parent interface' and 'PPP interface' are the same in the DSL/PPPoE tab, in the Edit connection window. – cristian mos Mar 26 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.