1

I have a 32" 4k screen that is recognized as a 27" screen and my cursor is huge.

When I try to adjust the cursor size using the DCONF editor no changes are actually made to the cursor size, even after a reboot. The same is true for adjusting the cursor theme using elementary tweaks.

I also found my settings for setting suspend time to "never" did not work, which led me to this solution. Could the same thing be happening with cursor settings? I need to change the cursor size and theme for the user "lightdm", not my user?

I'm a bit new to Linux, so if anyone knows how to change the cursor size for "lightdm" please do share the commands that would need to be entered in terminal to do so.

Elementary OS 5.0 Juno

Thanks in advance

1

Derek, welcome to the Elementary OS forums!

I had a similar experience with Elementary OS - Juno and a Razer Blade Stealth which is equipped with a 13.3-inch QHD display. The resolution comes in at a whopping (3200 x 1800). In my case, everything was super tiny.

So I used System Settings -> Universal Access -> Display to change my display text size.

Then, I went to dconf Editor (installed through AppCenter) and followed this path: org > gnome > desktop > interface > cursor-size
I switched off use default value, and doubled my cursor size in the bottom field labeled Custom value. I saved my selection by clicking the check mark in the lower right hand side of the window.

Then I "waved" the cursor around, tried launching LibreOffice, there was no change with my cursor. So I tried a reboot, still nothing, the cursor stubbornly remained the same [small] size.

After that experience, I turned to Gnome Tweaks (available through AppCenter). I noticed that if I went to Appearance > Themes > Cursor and changed it from Elementary to Adwaita (default). My cursor suddenly increased in size. However, and this is where it gets interesting. Wherever the Pantheon desktop environment holds sway, my cursor will revert back to the same small size. For example, this would include the Dock, Desktop, Window headers, etc... So, I can not claim this is a 100% fix, but this irregularity may become something that is patched in a future update.

I hope that helps! Good luck.

  • That is interesting! I should have included this in my original post but did not; when my mouse is in a window (chrome, LibreOffice, Pycharm, Mendeley, etc.), the cursor is an appropriate size. It is only huge when it is on the login screen, dock, desktop, and window headers, just like you mentioned! So, maybe the dconf Editor settings are working on my computer, but only when my cursor is in a non-Pantheon environment? I should test this and see if my cursor size changes in windows when I change the value in dconf editor. Thank you! – Derek Mar 12 at 19:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.