1

I'm struggling since a while with my NIC "Broadcom Limited NetLink BCM57780 Gigabit Ethernet PCIe" which can not be connected to any device using ethernet. The link is always down.

I tried to change speed using ethtool to 10 / 100 / 1000 Mb/s and change autoneg but nothing changed the link always appears to be down and I can't ping anyone but myself.

I also tried to download driver on this : https://download.cnet.com/Broadcom-LAN-Driver-8-27-1-0-zip/3000-2112_4-162569.html seems like there's a Linux driver inside but I never managed to compile it.

I Tried to set an IP and bring interface up manually, it went up through UI but still appeared down through ethtool and via "dmesg | grep tg3".

I'm quite new on Linux, I think this is a driver problem here but I can't find any for my NCI...

[Edit] : According to https://unix.stackexchange.com/questions/118850/no-wired-ethernet-connection I have the following output when using lshw:

$ sudo lshw -c network -sanitize:
*-network
   description: Ethernet interface
   produit: NetLink BCM57780 Gigabit Ethernet PCIe
   fabriquant: Broadcom Inc. and subsidiaries
   identifiant matériel: 0
   information bus: pci@0000:0e:00.0
   nom logique: enp14s0
   version: 01
   numéro de série: [REMOVED]
   taille: 100Mbit/s
   capacité: 1Gbit/s
   bits: 64 bits
   horloge: 33MHz
   fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=off broadcast=yes driver=tg3 driverversion=3.137 duplex=full firmware=sb latency=0 link=no multicast=yes port=MII speed=100Mbit/s
   ressources: irq:36 mémoire:d3400000-d340ffff

Seems like this is enough to say that there is an actual driver (tg3 v3.137) attached to my Ethernet device and that's at least getting detected by the kernel during boot.

Thus, it doesn't seem to be a missing driver problem. I'm quite lost now...

Does anyone already solved this kind of problem with this kind of NCI ?

Other information :

  • Linux version : 4.15.0-45-generic ;
  • My PC is an Aspire-V3-772 ;
  • I used to be on Windows 10 and never had any problem with my NCI, but it seems like it never worked on Linux for me.
  • The workaround : Buy an USB to Ethernet adapter. I'm still interested if someone find out how to fix the problem btw. – fratso May 3 at 22:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.