I've foolishly changed my screenshot settings, and want to set them back to have the same short cuts. I could boot a live USB / DVD but I'd rather not have to restart right now.

How can I reset all the shortcuts?

2 Answers 2


Use gsettings.

I'm going to specifically answer this for the screenshot shortcuts, but you can change it to work for you.

First, we're going to open terminal list all of the options we can change, but filter out the ones we don't want (or more accurately only show the ones we do).

gsettings list-recursively  | grep screenshot

You will see a list like this (click here to see all the output):

org.gnome.settings-daemon.plugins.media-keys window-screenshot ''
org.gnome.settings-daemon.plugins.media-keys screenshot-clip ''
org.gnome.settings-daemon.plugins.media-keys window-screenshot-clip '<Alt>Print'
org.gnome.settings-daemon.plugins.media-keys area-screenshot-clip ''
org.gnome.settings-daemon.plugins.media-keys screenshot 'Print'
org.gnome.settings-daemon.plugins.media-keys area-screenshot '<Shift><Alt>Print'

Just so you know, -clip means it saves to clipboard, the others are fairly self explanatory.

We want to reset them - to have "window-screenshot" reset. "window-screenshot" has the path org.gnome.settings-daemon.plugins.media-keys.

gsettings has a reset argument (like we use the list-recursively option). That's what we're going to use to get it back to what it was.

So, this is the command:

gsettings reset org.gnome.settings-daemon.plugins.media-keys window-screenshot

and now it is reset. Run the original command again to check, and you'll see an output like this:

org.gnome.settings-daemon.plugins.media-keys window-screenshot '<Alt>Print'

A quick explanation if you don't want to reset screenshot keys. For this one, I'll show media keys.

The key we want to grep for is media or media-keys, and here is a section of the output:

org.gnome.settings-daemon.plugins.media-keys pause 'XF86AudioPause'
org.gnome.settings-daemon.plugins.media-keys active true
org.gnome.settings-daemon.plugins.media-keys area-screenshot '<Shift><Alt>Print'
org.gnome.settings-daemon.plugins.media-keys logout '<Control><Alt>Delete'
org.gnome.settings-daemon.plugins.media-keys screenreader '<Alt><Super>s'
org.gnome.settings-daemon.plugins.media-keys volume-mute 'XF86AudioMute'
org.gnome.settings-daemon.plugins.media-keys volume-up 'XF86AudioRaiseVolume'

then you can simply follow the same instructions above for the new path.

  • my paste shortcut as overrrided from clipboard app, now not work CTRL+V for paste, why solve it?
    – flourigh
    Commented Feb 17, 2019 at 14:14

In System Settings > About There is a button "Restore Default Settings". You can use this to reset all system settings back to their factory defaults.

This will not affect any application settings.


  • 1
    This does everything not just keyboard short cuts though?
    – user3
    Commented Jul 9, 2015 at 9:36
  • That's correct, it will reset all system-level settings Commented Jul 9, 2015 at 17:25
  • 1
    I couldn't find the button you are referring to in Freya. Was it moved or removed?
    – Jake
    Commented Sep 27, 2015 at 17:54
  • I noticed you added the Image. I did a clean install today and I don't have this button. That's strange... imgur.com/RJAjop1
    – Jake
    Commented Sep 27, 2015 at 19:48
  • @Jake Notice that you're running 0.3. not 0.3.1 You need to run your updates ;) Commented Sep 28, 2015 at 5:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.