0

New Linux user here. I just installed Elementary OS Juno on my MS Surfacebook. What I've noticed is that in the Files app, it REALLY wants to launch the parent app. I just have to select a document and in a second, the app is launched.

That's a bit hyper active. Is there any way to have select JUST select the file and wait for a double click to open?

3
  • I understand why you need this, but this is part of the design of eOS. Can you try it for a few days before you install the tweaks as answered below? I had the same issue with it, but now I'm used to it. :)
    – Sterex
    Feb 19 '19 at 21:31
  • I'm a UX designer. Telling me to 'just get used to it' is waving a red flag in my face ;-) It's actually quite arrogant of eOS to assume that 95+% of the desktop users on the planet (Mac + Windows) are wrong. For switchers like me, forcing me into such a new behavior is not friendly at all. Finally, I've only heard a MILLION times that the beauty of Linux is that it's flexible. Not having an option to turn it off flies in the face of that core belief. Feb 20 '19 at 23:49
  • I'm sorry. I did not mean to be condescending. I've been with Linux long enough to appreciate it's flexibility. :) I think the thing I was looking for in eOS was the relief that I DON'T have to configure everything like I have to in other distros. But I understand (like I did before too) that you need it. Also having to try a different things to improve the UX is what you do as a UX designer no? ;) Finally, I have heard from a lot of new people trying Linux that the community is harsh/rude. I don't want you to feel the same way. Please enjoy Linux the way you prefer to! And welcome! :)
    – Sterex
    Feb 21 '19 at 6:38
0

You can install elementary tweaks to adjust various settings to your liking (amongst which changing the single click behaviour). Run these commands to install it:

sudo apt install software-properties-common
sudo add-apt-repository ppa:philip.scott/elementary-tweaks 
sudo apt install elementary-tweaks

Then open settings, select tweaks, go to the "files" tab and uncheck single click.

2
  • This was exactly what I needed thank you. As I'm new in this corner to stack overflow, I'm apparently not allowed to mark this as "this answered my question" Feb 19 '19 at 0:58
  • 1
    Actually, I can now. Marked as answered. Thank you! Feb 20 '19 at 23:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.