3

I recently started using elementary OS and installed Firefox as my browser. I'm currently having a problem with the dropdowns, like the context menu or the input suggestion as they appear in wrong locations.

You can see attached two examples of it. In one of the examples you see how whenever I do right click the context menu opens with the cursor on the middle of it instead of showing up on the bottom right of the cursor (as it usually is).

Context menu

In the other example you can see how whenever I'm feeling a form and I get a suggestion for filling the input, the suggestion appears somewhere above the input bar, instead of appearing exactly bellow it.

Input suggestion

Anyone that could help out with this problem?

  • It happens to me too but at random intervals. Sometimes they work correctly and sometimes they don't. – dsSTORM Feb 16 at 18:33
  • For me it always happens, but sometimes it changes the position. It is weird. Any idea what might be causing it? I tried for hours to find a solution but I found nothing by googling – Miguel Arduz Feb 16 at 20:12
  • 1
    No clue at all. I may decide to try the firefox 66 beta (installing it via snap) and see if it persists there too. But I'm afraid there's next to nothing we can do at a user level for this. – dsSTORM Feb 16 at 22:20
  • Let me know if it solves the problem, please! Then I would do it also – Miguel Arduz Feb 17 at 20:01
1

Thanks to @dsSTORM for giving the idea to download Firefox via snap. I just did and the problem was solved completely!

0

If you have an existing profile that you don't want to lose, and if you're not using Firefox Sync, you may run into difficulties trying to migrate that profile into the Firefox snap.

For what it's worth, I think I made this problem go away by resetting the toolbar positions. I think? It seems so... unrelated... but maybe?

That is,

  • choose "Customize..." from the hamburger menu, then
  • click the "Restore Defaults" button in the lower-right.

After upgrading to Juno, I ran into this problem, and it was like driving-me-mad annoying, but using the snap wasn't an option for me, since I'm running Nightly, and Firefox blocks you from using existing profiles with older versions of Firefox, ostensibly to prevent data corruption.

Anyway today, after either restoring the default toolbar positions, or a Nightly update, or some unrelated OS update, the problem is gone. ¯\_(ツ)_/¯

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.