Shortly after executing "sudo apt-get update" in Terminal I ran the remaining updates in the App Center. Once I started with these updates, I changed user accounts (stayed logged in to both). It was functional at first, I got to a new webpage before my entire OS stopped working. I could move my mouse but there would be no response from the computer.

After about 10 minutes waiting I forced computer shutdown manually and when I restarted the computer it stops mid-boot, listing the call trace and summary.

The error message that I'm getting mid-boot is: "Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0, 0)"

3 Answers 3


Choose another kernel from the GRUB menu under Advanced options for Ubuntu and run sudo update-initramfs -u -k version to generate the initrd for version (replace version with the kernel version string such as 4.15.0-36-generic) then sudo update-grub.


I had the same problem. I tried removing the kernels manually with first listing them:

"dpkg --list | grep linux-image"

Then removing them with:

sudo apt-get purge linux-image-3.13.0-XX-generic

But then I got an error and I was suggested to use:

sudo dpkg --configure -a

This was what solved my problem.


Actually,it is not even necessary to remove older kernel. Just select during boot in grub the older kernel, run it, log to system, open terminal and type:

sudo dpkg --configure -a

Additionally, what I recommend, is to check kernels this way:

sudo dpkg --list | grep linux-image

And then

sudo update-initramfs -u -k 5.0.4-generic 

(use the version of the kernel which is damaged and shows kernel panic)

Then update grub

sudo update-grub

If sudo update-grub will not work, then type:

sudo grub-mkconfig -o /boot/grub/grub.cfg

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.