Many programs stop replying to the letter keys on the keyboard when switching to the Russian layout. For example, a blender. Both Inkscape and Gimp have problems. In Ubuntu, POP! OS, Manjaro, Open Suse, no problem.

This acute problem is still unresolved. Please pay attention of the developers.


2 Answers 2


This should be fixed by entering the following commands to enable the hotkeys for the Russian keyboard layout:

sudo add-apt-repository ppa:attent/java-non-latin-shortcuts

sudo apt-get update

sudo apt-get dist-upgrade

restart unity-setting-daemon

After then you should restart your computer and check whether the hotkeys are working correctly.

  • Not working/ Cannot add PPA: 'ppa:~attent/ubuntu/java-non-latin-shortcuts'. ERROR: '~attent' user or team does not exist sudo add-apt-repository ppa:attente/java-non-latin-shortcuts Error: retrieving gpg key timed out. Commented May 7, 2019 at 0:01
  • ppa:attent/java-non-latin-shortcuts not supported ubuntu 18.04 Commented Jun 24, 2019 at 2:20

Concerning non-working keyboard shortcuts for Russian keyboard layout: I have reported this issue to blender developers (see here). Based on their answer, this might be OS-specific (i.e. not Linux-specific, but elementary OS-specific) issue, because Russian shortcuts seem to work fine in blender on Ubuntu 18.04.

@moderator I'd like to report this issue as a bug. Which channel would you suggest as appropriate for this kind of issue?

  • I still don't know if there's a solution to the problem. Commented May 21, 2019 at 6:51
  • @Hasan That's not the right repo in this case. That repo contains the code for the keyboard settings panels, which have nothing to do with keyboard usage in general. Commented Jul 16, 2019 at 13:03
  • @PeterUithoven I am sorry for the mistake. Can you please help me by telling which one is the right one or please post the right one, i am deleting my comment. Thank you very much for pointing that out.
    – Hasan
    Commented Jul 16, 2019 at 13:49
  • 1
    @Hasan I'd open it in the catch all "OS" repo, because it's quite unclear where this issue comes from. Commented Jul 17, 2019 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.