1

I added an entry to auto mount disk on startup by editing fstab. It looks like something went wrong with the entry and now I cannot boot it up

Is there any way to access the OS?

  • Yes. Try booting up with a live USB, go with the try mode and clear the mess from fstab. – Hasan Feb 9 at 7:49
0

Create Live USB and use that to edit your fstab file. below is example of mine. but read carefully.

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=<your-UUID-FOR-/-PARTITION> /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda2 during installation
UUID=<your-UUID-FOR-/BOOT/EFI-PARTITION(IF YOU USE UEFI)>  /boot/efi       vfat    umask=0077      0       1
# swap was on /dev/sda7 during installation
UUID=<your-UUID-FOR-SWAP-PARTITION> none            swap    sw              0       0


use command:

blkid

to get your disk UUID. after finish editing your fstab, reboot.

Thank you.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.