0

Recently I installed the latest release of Firefox stable, version 65. Since the upgrade, Firefox is unusable. When attempting to load a web page, both through bookmarks and typed in addresses, it will begin to load the page, then drop and leave me with a blank page. Click on the hamburger menu is unresponsive as well. Prior to the upgrade to v65, everything was working correctly. I've disabled all my addons through about:addons (which did display correctly) and the behavior is still the same. I realize this may be better posted on a support page for Firefox, but figured I'd see if any other elementary users are experiencing this, as the upgrade to 65 completed without issue for both of my ubuntu boxes.

1

So, I may have figured it out. I 'refreshed' Firefox, and everything seems to be okay for now. If you want to give this a shot, head over to about:support and there will be a link there to refresh.

I wanted to avoid doing this because of concerns of loss of data and whatnot, but if you have a Firefox Sync account, it really is painless.

Oddly, with dozens of upgrades over the years, this is the first time I've ever had to refresh Firefox to resolve an issue following an update.

1

Update:

I've found a fix of sorts. My firefox has been stable for the last few days and yesterday I changed the browser to display the tabs in the titlebar and all the problems came back. Pages wouldn't load, the rightclick menu didn't work etc. When I changed the titlebar setting back Firefox started to behave normally again.

I have this as well.

Sometimes it can take a while for the bug to manifest, but when it triggers only a reboot will fix it, and then only to a certain extent. Even after a reboot when rightclicking on links the menu won't stay open, you have to keep the button pressed down.

When it happens all subsequent websites won't work.

Edit:

Unfortunately I already tried refreshing FF and the problem returned after a while.

I also tried making a completely new profile and the same thing happened.

  • The refresh worked for one of my Elementary installs, but not the other. It appeared to have worked for about six hours, like what you're experiencing. I haven't tried creating a new profile yet. – F. Strelok Feb 4 at 18:02
  • I thought the problem had disappeared as FF worked the last couple of days but then it returned yesterday and nothing was able to fix it. I've created a new profile and refreshed FF so now I'll see how long this lasts. – Morten Strårup Feb 7 at 18:07
  • I had the same experience. I refreshed Firefox, and it worked without issue for about a week. Just this morning it started showing the same behavior.. I refreshed again, and I'm back to having a usable browser. – F. Strelok Feb 10 at 16:55
  • I don't have the same exact problems, but for sure Firefox 65 broke something. Randomly (at least, it seems) Firefox stops opening pages. It does get to the address, you can see the favicon and the site name in the tab, but the page stays completely blank. I tried to delete cache & cookies, disable hardware acceleration and refresh Firefox but the problem randomly comes back. The only pattern MIGHT always having an Outlook Mail tab open when it happened... maybe? – Travis 2 days ago
  • I think I managed to find a pattern: you can recreate the problem when you click on the Firefox icon in the dock, to minimize the window. When reopened, nothing will be displayed in a newly opened tab, just a blank page. Idea? – Travis 2 days ago

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.