3

I like to use Alt+Tab (the default shortcut for "Switch Windows") inside a particular program¹.

As a result, I would like to use Win+Tab and Shift+Win+Tab to switch windows instead. I've already modified the "Switch Windows" and "Switch Windows backwards" keyboard shortcuts in System Settings:

Switch Windows key bindings

This causes the new Win shortcuts to switch windows, but the old Alt shortcuts still switch windows as well. My goal is to free these shortcuts from the desktop.

Is there a way to completely unbind Alt+Tab and Shift+Alt+Tab at the OS level?

¹Not that it's terribly important, but I use this key combination to trigger code completion in Emacs. I'm pretty used to it, and would prefer not to change the binding.

closed as off-topic by Daniel Foré, Aditya ultra, Rafael, John Guerreiro, Sanjay Karki Sep 6 '15 at 6:15

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • I'm going to mark this as "off topic" as a bug report. If you've changed the shortcut, but Gala is still swallowing the old ones that is a bug. Please refer to elementary.io/docs/code/reference#reporting-bugs – Daniel Foré Sep 5 '15 at 16:08
  • 1
    @DanielForé, thanks for the suggestion. I'll head over to Launchpad and report this as a bug. In the mean time, I've found a workaround (see below). I will leave the question and answer up in case they help somebody else. – Chris Sep 5 '15 at 16:22
4

I discovered a workaround via this answer to a related question.

First, use gsettings to find the internal configuration setting we wish to change:

gsettings list-recursively | grep -i switch
# ...
# org.gnome.desktop.wm.keybindings switch-applications ['<Super>Tab', '<Alt>Tab']
# ...

Then, change the individual setting as necessary. In this case:

gsettings set org.gnome.desktop.wm.keybindings switch-applications "['<Super>Tab']"

As suggested by Daniel in the comments above, I have reported this as a bug.

Not the answer you're looking for? Browse other questions tagged or ask your own question.